Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile.helpers
diff options
context:
space:
mode:
authorDaniel Narvaez <dwnarvaez@gmail.com>2012-11-20 08:41:21 (GMT)
committer Daniel Narvaez <dwnarvaez@gmail.com>2012-11-20 08:41:21 (GMT)
commit3aee5544e9166e7ebc000d6be2c2340e25c7a720 (patch)
tree67b17f44de7b75053fffb986cf7a14b020c43e5e /Makefile.helpers
parent888687f307f77738b2209dfc0f48f8f30aa63b58 (diff)
Split and cleanup makefiles
Diffstat (limited to 'Makefile.helpers')
-rw-r--r--Makefile.helpers14
1 files changed, 6 insertions, 8 deletions
diff --git a/Makefile.helpers b/Makefile.helpers
index 69eb57e..79f30eb 100644
--- a/Makefile.helpers
+++ b/Makefile.helpers
@@ -1,17 +1,15 @@
-.PHONY: helpers clean-helpers
-
-HELPERS = $(COMMANDS)/helpers
+.PHONY: helpers-build helpers-clean
HELPERS_LIBS = $(shell pkg-config --libs xrandr x11)
$(HELPERS)/%: $(HELPERS)/%.c
gcc -o $@ $< $(HELPERS_LIBS)
-bin_HELPERS = $(HELPERS)/list-outputs \
- $(HELPERS)/find-free-display \
- $(HELPERS)/xephyr-window
+bin_HELPERS = $(HELPERS_DIR)/list-outputs \
+ $(HELPERS_DIR)/find-free-display \
+ $(HELPERS_DIR)/xephyr-window
-helpers: $(bin_HELPERS)
+helpers-build: $(bin_HELPERS)
-clean-helpers:
+helpers-clean:
rm -f $(bin_HELPERS)