Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Narvaez <dwnarvaez@gmail.com>2012-11-16 14:24:40 (GMT)
committer Daniel Narvaez <dwnarvaez@gmail.com>2012-11-16 14:24:40 (GMT)
commit07f237ba496428453896cdfaf9973c1a0590e10f (patch)
tree2136dd5e689afac3853249e47a817cff97fecc4a /Makefile
parent4ffa3068a14518f07a0c100521413a9c7bcbaae5 (diff)
Cleanup makefiles
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile45
1 files changed, 15 insertions, 30 deletions
diff --git a/Makefile b/Makefile
index 7b796d5..4704657 100644
--- a/Makefile
+++ b/Makefile
@@ -1,44 +1,29 @@
COMMANDS = $(CURDIR)/commands
-all: build
-
-XRANDR_LIBS = $(shell pkg-config --libs xrandr x11)
-X11_LIBS = $(shell pkg-config --libs x11)
-
-commands/helpers/list-outputs: commands/helpers/list-outputs.c
- gcc -o commands/helpers/list-outputs \
- commands/helpers/list-outputs.c $(XRANDR_LIBS)
+include Makefile.helpers
-commands/helpers/find-free-display: commands/helpers/find-free-display.c
- gcc -o commands/helpers/find-free-display \
- commands/helpers/find-free-display.c $(X11_LIBS)
-
-x11-utils: commands/helpers/list-outputs commands/helpers/find-free-display
+all: build
check-system:
- $(COMMANDS)/check-system $(ARGS)
+ @$(COMMANDS)/check-system $(ARGS)
build: check-system
- $(COMMANDS)/build
+ @$(COMMANDS)/build
-run: x11-utils
- $(COMMANDS)/run
+run: helpers
+ @$(COMMANDS)/run
-run-command: x11-utils
- $(COMMANDS)/run-command
+run-command: helpers
+ @$(COMMANDS)/run-command
-test: x11-utils
- $(COMMANDS)/test
+test: helpers
+ @$(COMMANDS)/test
-shell: x11-utils
- @PS1="[sugar-build \W]$$ " \
- $(COMMANDS)/shell
+shell: helpers
+ @$(COMMANDS)/shell
bug-report:
- $(COMMANDS)/bug-report
+ @$(COMMANDS)/bug-report
-clean:
- $(COMMANDS)/clean
- rm -f logs/*.log logs/all-logs.tar.bz2
- rm -f scripts/list-outputs
- rm -f scripts/find-free-display
+clean: clean-helpers
+ @$(COMMANDS)/clean