Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Narvaez <dwnarvaez@gmail.com>2012-11-20 08:41:21 (GMT)
committer Daniel Narvaez <dwnarvaez@gmail.com>2012-11-20 08:41:21 (GMT)
commit3aee5544e9166e7ebc000d6be2c2340e25c7a720 (patch)
tree67b17f44de7b75053fffb986cf7a14b020c43e5e /Makefile
parent888687f307f77738b2209dfc0f48f8f30aa63b58 (diff)
Split and cleanup makefiles
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile37
1 files changed, 6 insertions, 31 deletions
diff --git a/Makefile b/Makefile
index f639f60..f8e002c 100644
--- a/Makefile
+++ b/Makefile
@@ -1,36 +1,11 @@
-COMMANDS = $(CURDIR)/commands
+SOURCE_DIR=$(CURDIR)/source
+COMMANDS_DIR=$(CURDIR)/commands
+HELPERS_DIR=$(COMMANDS_DIR)/helpers
-.PHONY: all auto-install check-system build run test shell bug-report clean \
- upload-docs
+.PHONY: all
all: build
-auto-install:
- @$(COMMANDS)/auto-install
-
-check-system:
- @$(COMMANDS)/check-system $(ARGS)
-
-build: check-system
- @$(COMMANDS)/build
-
-run: helpers
- @$(COMMANDS)/run
-
-test: helpers
- @$(COMMANDS)/test
-
-shell: helpers
- @$(COMMANDS)/shell
-
-bug-report:
- @$(COMMANDS)/bug-report
-
-clean: clean-helpers
- @$(COMMANDS)/clean
-
-upload-docs:
- rsync -r --progress ./source/sugar-docs/build/ \
- dnarvaez@shell.sugarlabs.org:~/public_html/sugar-docs/
-
+include Makefile.commands
include Makefile.helpers
+include Makefile.buildbot