Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Narvaez <dwnarvaez@gmail.com>2012-11-14 15:32:49 (GMT)
committer Daniel Narvaez <dwnarvaez@gmail.com>2012-11-14 15:40:37 (GMT)
commit66dc2e7ea7011ae63e1d404ebffeaa7782a7f2f5 (patch)
treea862db846c2bdb303a96108502402115eef40693 /Makefile
parentf83756431a5b6f8551f0902655ca39bf18a5e5b0 (diff)
Refactor check-system to use a devbot module
This is necessary to be able to share code, all the commands will be gradually refactored to follow this pattern.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index f9c3beb..9f71991 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,7 @@
TIMESTAMP := $(shell date +%Y%m%d-%H%M%S)
LOGFILE = $(CURDIR)/logs/build-$(TIMESTAMP).log
SCRIPTS = $(CURDIR)/scripts
+COMMANDS = $(CURDIR)/commands
DNBUILD = $(SCRIPTS)/dn-build
LOG = $(SCRIPTS)/log-command
@@ -26,7 +27,7 @@ scripts/find-free-display: scripts/find-free-display.c
x11-utils: scripts/list-outputs scripts/find-free-display
check-system:
- $(TYPESCRIPT) $(SCRIPTS)/check-system $(LOGFILE)
+ $(TYPESCRIPT) $(COMMANDS)/check-system $(LOGFILE)
build: check-system
$(LOG) "$(DNBUILD) build" $(LOGFILE)