Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Narvaez <dwnarvaez@gmail.com>2012-11-14 16:50:21 (GMT)
committer Daniel Narvaez <dwnarvaez@gmail.com>2012-11-14 16:50:21 (GMT)
commit9d88d6a8c38e1a35f5749d06214f92513414ed67 (patch)
tree32a7aeb593bb30fb2d9cd7df03438118576448ad /Makefile
parent66dc2e7ea7011ae63e1d404ebffeaa7782a7f2f5 (diff)
Refactor dnbuild into devbot
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 9f71991..60bb112 100644
--- a/Makefile
+++ b/Makefile
@@ -2,7 +2,6 @@ TIMESTAMP := $(shell date +%Y%m%d-%H%M%S)
LOGFILE = $(CURDIR)/logs/build-$(TIMESTAMP).log
SCRIPTS = $(CURDIR)/scripts
COMMANDS = $(CURDIR)/commands
-DNBUILD = $(SCRIPTS)/dn-build
LOG = $(SCRIPTS)/log-command
# The buildbot shell does not handle script properly. It's unnecessary
@@ -30,7 +29,7 @@ check-system:
$(TYPESCRIPT) $(COMMANDS)/check-system $(LOGFILE)
build: check-system
- $(LOG) "$(DNBUILD) build" $(LOGFILE)
+ $(LOG) "$(COMMANDS)/build" $(LOGFILE)
run: x11-utils
$(SCRIPTS)/shell/start-sugar
@@ -42,13 +41,13 @@ shell: x11-utils
@PS1="[sugar-build \W]$$ " \
PATH=$(PATH):$(SCRIPTS)/shell \
SUGAR_BUILD_SHELL=yes \
- $(DNBUILD) shell
+ $(COMMANDS)/shell
bug-report:
@$(SCRIPTS)/bug-report
clean:
- $(DNBUILD) clean
+ $(COMMANDS)/clean
rm -f logs/*.log logs/all-logs.tar.bz2
rm -f scripts/list-outputs
rm -f scripts/find-free-display