Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Narvaez <dwnarvaez@gmail.com>2012-11-12 12:54:26 (GMT)
committer Daniel Narvaez <dwnarvaez@gmail.com>2012-11-12 12:54:26 (GMT)
commit225625bcf34c80b3c6b7c80ca8f1360451a417b9 (patch)
tree80b0736c70983e82f6dd478e61cb8f7fefad74e6 /Makefile
parent21c7eb5927e4fa3d7585d68ae55f3d26a98422e6 (diff)
Build activities with a custom script
It should be faster and cleaner than the sugar-fructose hack. Eventually dn-build might replace jhbuild. We don't really need all that complexity.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 29643b5..85e32c9 100644
--- a/Makefile
+++ b/Makefile
@@ -40,10 +40,10 @@ install-jhbuild: submodules check-system
build-glucose: install-jhbuild check-system
$(TYPESCRIPT) "$(JHBUILD) build" $(LOGFILE)
-build-fructose:
- $(TYPESCRIPT) "$(JHBUILD) build -f sugar-fructose" $(LOGFILE)
+build-activities:
+ $(TYPESCRIPT) "$(JHBUILD) run $(SCRIPTS)/dn-build" $(LOGFILE)
-build: build-glucose build-fructose
+build: build-glucose build-activities
build-%:
$(TYPESCRIPT) "$(JHBUILD) buildone -f $*" $(LOGFILE)