Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Narvaez <dwnarvaez@gmail.com>2012-06-14 19:54:16 (GMT)
committer Daniel Narvaez <dwnarvaez@gmail.com>2012-06-14 19:54:53 (GMT)
commit51e2d72c322d8aee6c9bcc6dfc2941abd443fb12 (patch)
treeb8b7808fcb679228b01b06e61368c1a38c114631 /Makefile
parentb3d05dd224ee8d01307e2e079f6955b9581df90c (diff)
Add a bug-report command
This generates logs that will be useful for debugging.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index d3f1a7b..9f26760 100644
--- a/Makefile
+++ b/Makefile
@@ -1,3 +1,5 @@
+TIMESTAMP := $(shell date +%Y%m%d-%H%M%S)
+LOGFILE = $(CURDIR)/logs/build-$(TIMESTAMP).log
SCRIPTS = $(CURDIR)/scripts
JHBUILD = $(CURDIR)/build/bin/jhbuild -f $(SCRIPTS)/jhbuildrc
@@ -6,7 +8,7 @@ submodules:
git submodule update
check-system:
- $(SCRIPTS)/check-system
+ script -ae -c "$(SCRIPTS)/check-system" $(LOGFILE)
install-jhbuild: submodules check-system
cd $(SCRIPTS)/jhbuild ; \
@@ -14,19 +16,22 @@ install-jhbuild: submodules check-system
make ; make install
build-activities: submodules
- $(JHBUILD) run $(SCRIPTS)/build-activity terminal
+ $(JHBUILD) run $(SCRIPTS)/build-activity terminal | tee -a $(LOGFILE)
build-glucose: install-jhbuild check-system
- $(JHBUILD) build
+ script -ae -c "$(JHBUILD) build" $(LOGFILE)
build: build-glucose build-activities
build-%:
- $(JHBUILD) buildone $*
+ script -ae -c "$(JHBUILD) buildone $*" $(LOGFILE)
run:
xinit $(SCRIPTS)/xinitrc -- :2
+bug-report:
+ @$(SCRIPTS)/bug-report
+
clean:
- rm -rf source
- rm -rf build
+ rm -rf source build
+ rm -f logs/*.log all-logs.tar.bz2