Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Narvaez <dwnarvaez@gmail.com>2012-06-26 14:02:26 (GMT)
committer Daniel Narvaez <dwnarvaez@gmail.com>2012-06-26 14:02:26 (GMT)
commitd218ce894c57818d16fe21e1fdf240489f4303b6 (patch)
tree33ebd5772f651d9dc779148e04b229086bbffb2c /Makefile
parent30ed5839458e8039e1656b161d6964aca1d96995 (diff)
Build out of source directory when possible
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 68b8057..7ceebd3 100644
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,7 @@
TIMESTAMP := $(shell date +%Y%m%d-%H%M%S)
LOGFILE = $(CURDIR)/logs/build-$(TIMESTAMP).log
SCRIPTS = $(CURDIR)/scripts
-JHBUILD = $(CURDIR)/build/bin/jhbuild -f $(SCRIPTS)/jhbuildrc
+JHBUILD = $(CURDIR)/install/bin/jhbuild -f $(SCRIPTS)/jhbuildrc
LOG = $(SCRIPTS)/log-command
# The buildbot shell does not handle script properly. It's unnecessary
@@ -28,7 +28,7 @@ check-system:
install-jhbuild: submodules check-system
cd $(SCRIPTS)/jhbuild ; \
- ./autogen.sh --prefix=$(CURDIR)/build ; \
+ ./autogen.sh --prefix=$(CURDIR)/install ; \
make ; make install
build-activities: submodules
@@ -57,6 +57,6 @@ bug-report:
@$(SCRIPTS)/bug-report
clean:
- rm -rf source build
+ rm -rf source build install
rm -f logs/*.log logs/all-logs.tar.bz2
rm -f scripts/list-outputs