Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/devbot/build.py
diff options
context:
space:
mode:
authorDaniel Narvaez <dwnarvaez@gmail.com>2013-02-06 14:40:44 (GMT)
committer Daniel Narvaez <dwnarvaez@gmail.com>2013-02-06 14:40:44 (GMT)
commitcca8146fc939b564256237eb4fda8e47132673de (patch)
treed3c16679ad3deb6811d83538090bb07d39723463 /devbot/build.py
parentf6bf5049d4f7eb219c548013baf4f4a1dc8f5b09 (diff)
Add b2g
Diffstat (limited to 'devbot/build.py')
-rw-r--r--devbot/build.py17
1 files changed, 14 insertions, 3 deletions
diff --git a/devbot/build.py b/devbot/build.py
index 694c478..d4ed2b6 100644
--- a/devbot/build.py
+++ b/devbot/build.py
@@ -133,10 +133,8 @@ def _build_autotools(module, log):
aclocal_path = os.path.join(config.share_dir, "aclocal")
utils.ensure_dir(aclocal_path)
- makefile_path = os.path.join(module.get_build_dir(), "Makefile")
-
source_dir = module.get_source_dir()
- if not os.path.exists(makefile_path):
+ if not os.path.exists("Makefile"):
configure = os.path.join(source_dir, "autogen.sh")
if not os.path.exists(configure):
configure = os.path.join(source_dir, "configure")
@@ -180,6 +178,19 @@ def _build_node(module, log):
_builders["node"] = _build_node
+def _build_mozilla(module, log):
+ obj_dir = "obj-%s" % module.name
+ dist_bin_dir = os.path.join(obj_dir, "dist", "bin")
+ install_dir = os.path.join(config.lib_dir, module.name)
+
+ with open("mozconfig", "w") as f:
+ f.write("ac_add_options --enable-application=%s\n" % module.name)
+ f.write("mk_add_options MOZ_OBJDIR=%s" % obj_dir)
+
+ #command.run(["make", "-f", "client.mk"], log)
+ command.run(["cp", "-vRL", "%s/" % dist_bin_dir, install_dir], log)
+
+_builders["mozilla"] = _build_mozilla
def _distribute_autotools(module):
makefile = parse_makefile("Makefile")