Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/devbot/config.py
diff options
context:
space:
mode:
authorDaniel Narvaez <dwnarvaez@gmail.com>2013-01-29 09:38:19 (GMT)
committer Daniel Narvaez <dwnarvaez@gmail.com>2013-01-29 09:38:19 (GMT)
commit1df51c324c13178b060c4968d244677af069948d (patch)
treec16f9b73c076118eb71fbf3d13a9a51a8ee137d0 /devbot/config.py
parentd4b64dbd3f047ea86dfbe17e149ed813e4cff6d3 (diff)
Add node
Diffstat (limited to 'devbot/config.py')
-rw-r--r--devbot/config.py7
1 files changed, 5 insertions, 2 deletions
diff --git a/devbot/config.py b/devbot/config.py
index d444869..17283c8 100644
--- a/devbot/config.py
+++ b/devbot/config.py
@@ -33,7 +33,9 @@ class Module:
self.tag = info.get("tag", None)
self.auto_install = info.get("auto-install", False)
self.options = info.get("options", [])
- self.options_evaluated = info.get("options_evaluated", [])
+ self.options_ev = info.get("options_ev", [])
+ self.extra_options = info.get("extra_options", [])
+ self.extra_options_ev = info.get("extra_options_ev", [])
self.has_checks = info.get("has_checks", False)
self.distribute = info.get("distribute", False)
@@ -52,7 +54,8 @@ class Module:
source_dir = self.get_source_dir()
if os.path.exists(os.path.join(source_dir, "setup.py")):
return "activity"
- elif os.path.exists(os.path.join(source_dir, "autogen.sh")):
+ elif os.path.exists(os.path.join(source_dir, "autogen.sh")) or \
+ os.path.exists(os.path.join(source_dir, "configure")):
return "autotools"
else:
print("The source directory has unexpected content, please "