Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/devbot
diff options
context:
space:
mode:
authorDaniel Narvaez <dwnarvaez@gmail.com>2013-02-06 14:40:44 (GMT)
committer Daniel Narvaez <dwnarvaez@gmail.com>2013-02-06 14:40:44 (GMT)
commitcca8146fc939b564256237eb4fda8e47132673de (patch)
treed3c16679ad3deb6811d83538090bb07d39723463 /devbot
parentf6bf5049d4f7eb219c548013baf4f4a1dc8f5b09 (diff)
Add b2g
Diffstat (limited to 'devbot')
-rw-r--r--devbot/build.py17
-rw-r--r--devbot/config.py5
-rw-r--r--devbot/environ.py2
-rw-r--r--devbot/state.py4
4 files changed, 24 insertions, 4 deletions
diff --git a/devbot/build.py b/devbot/build.py
index 694c478..d4ed2b6 100644
--- a/devbot/build.py
+++ b/devbot/build.py
@@ -133,10 +133,8 @@ def _build_autotools(module, log):
aclocal_path = os.path.join(config.share_dir, "aclocal")
utils.ensure_dir(aclocal_path)
- makefile_path = os.path.join(module.get_build_dir(), "Makefile")
-
source_dir = module.get_source_dir()
- if not os.path.exists(makefile_path):
+ if not os.path.exists("Makefile"):
configure = os.path.join(source_dir, "autogen.sh")
if not os.path.exists(configure):
configure = os.path.join(source_dir, "configure")
@@ -180,6 +178,19 @@ def _build_node(module, log):
_builders["node"] = _build_node
+def _build_mozilla(module, log):
+ obj_dir = "obj-%s" % module.name
+ dist_bin_dir = os.path.join(obj_dir, "dist", "bin")
+ install_dir = os.path.join(config.lib_dir, module.name)
+
+ with open("mozconfig", "w") as f:
+ f.write("ac_add_options --enable-application=%s\n" % module.name)
+ f.write("mk_add_options MOZ_OBJDIR=%s" % obj_dir)
+
+ #command.run(["make", "-f", "client.mk"], log)
+ command.run(["cp", "-vRL", "%s/" % dist_bin_dir, install_dir], log)
+
+_builders["mozilla"] = _build_mozilla
def _distribute_autotools(module):
makefile = parse_makefile("Makefile")
diff --git a/devbot/config.py b/devbot/config.py
index 3f65417..be1809b 100644
--- a/devbot/config.py
+++ b/devbot/config.py
@@ -54,8 +54,11 @@ class Module:
source_dir = self.get_source_dir()
if os.path.exists(os.path.join(source_dir, "setup.py")):
return "activity"
+ elif os.path.exists(os.path.join(source_dir, "mozilla-config.h.in")):
+ return "mozilla"
elif os.path.exists(os.path.join(source_dir, "autogen.sh")) or \
- os.path.exists(os.path.join(source_dir, "configure")):
+ os.path.exists(os.path.join(source_dir, "configure")) or \
+ os.path.exists(os.path.join(source_dir, "Makefile")):
return "autotools"
elif os.path.exists(os.path.join(source_dir, "package.json")):
return "node"
diff --git a/devbot/environ.py b/devbot/environ.py
index a9643de..cde6305 100644
--- a/devbot/environ.py
+++ b/devbot/environ.py
@@ -23,6 +23,8 @@ def setup_variables():
add_path("LD_LIBRARY_PATH", config.lib_dir)
add_path("PATH", config.bin_dir)
+ add_path("B2G_PATH",
+ os.path.join(config.lib_dir, "b2g"))
add_path("XCURSOR_PATH",
os.path.join(config.share_dir, "icons"))
add_path("PKG_CONFIG_PATH",
diff --git a/devbot/state.py b/devbot/state.py
index 0a6f7b9..6bf7139 100644
--- a/devbot/state.py
+++ b/devbot/state.py
@@ -103,6 +103,10 @@ def _save_state(name, state):
def _compute_mtime_hash(path):
+ # Too slow to compute the hash
+ if path.endswith("source/b2g"):
+ return "unchanged"
+
# For some reason if path is unicode we
# get a 10x slow down for some directories
path = str(path)