Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorDaniel Narvaez <dwnarvaez@gmail.com>2012-11-12 19:47:26 (GMT)
committer Daniel Narvaez <dwnarvaez@gmail.com>2012-11-12 19:47:26 (GMT)
commit7e9aee8e38e1680057ac4409774f1de67cc6efa2 (patch)
tree28cb90e91988207507cc925074c3287d6fd25574 /scripts
parent14740279b23f591fe9ff486493d3ed4628299628 (diff)
Delete libtool files
They only give issues
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/dn-build14
1 files changed, 13 insertions, 1 deletions
diff --git a/scripts/dn-build b/scripts/dn-build
index ec97b92..df9c414 100755
--- a/scripts/dn-build
+++ b/scripts/dn-build
@@ -1,6 +1,7 @@
#!/usr/bin/python -u
from distutils import sysconfig
+import glob
import json
import os
import multiprocessing
@@ -54,8 +55,8 @@ def get_module_build_dir(module):
def get_module_commit_id(module):
orig_cwd = os.getcwd()
-
os.chdir(get_module_source_dir(module))
+
commit_id = subprocess.check_output(["git", "rev-parse", "HEAD"])
os.chdir(orig_cwd)
@@ -66,6 +67,15 @@ def run_command(args):
print " ".join(args)
subprocess.check_call(args)
+def unlink_libtool_files():
+ orig_cwd = os.getcwd()
+ os.chdir(lib_dir)
+
+ for filename in glob.glob("*.la"):
+ os.unlink(filename)
+
+ os.chdir(orig_cwd)
+
def pull_source(module):
module_dir = get_module_source_dir(module)
@@ -94,6 +104,8 @@ def build_autotools(module):
run_command(["make", "-j", "%d" % jobs])
run_command(["make", "install"])
+ unlink_libtool_files()
+
def build_activity(module):
run_command(["./setup.py", "install", "--prefix", install_dir])