Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--Makefile.tests10
2 files changed, 6 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index 570d49f..fa950e3 100644
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,7 @@
SOURCE_DIR=$(CURDIR)/source
BUILD_DIR=$(CURDIR)/build
COMMANDS_DIR=$(CURDIR)/commands
-HOME_DIR=$(CURDIR)/home
+TESTS_DIR=$(CURDIR)/tests
TOOLS_DIR=$(CURDIR)/tools
BASE_DIR=$(CURDIR)
TIME=time -f "\n= Time =\n\nreal\t%e\nuser\t%U\nsys\t%S\n"
diff --git a/Makefile.tests b/Makefile.tests
index 3ece9dd..5438b55 100644
--- a/Makefile.tests
+++ b/Makefile.tests
@@ -1,10 +1,10 @@
-TESTS_DATA=$(HOME_DIR)/testsdata
+TESTS_TMP=$(TESTS_DIR)/tmp
test-devbot:
- mkdir -p $(TESTS_DATA) && \
+ mkdir -p $(TESTS_TMP) && \
cd tests/devbot && \
- TMPDIR=$(TESTS_DATA) PYTHONPATH=$(BASE_DIR) python -m unittest discover
- rm -rf $(TESTS_DATA)
+ TMPDIR=$(TESTS_TMP) PYTHONPATH=$(BASE_DIR) python -m unittest discover
+ rm -rf $(TESTS_TMP)
PYTHON_SCRIPTS = \
$(COMMANDS_DIR)/build \
@@ -21,4 +21,4 @@ PYTHON_SCRIPTS = \
pep8:
pep8 commands devbot tests $(PYTHON_SCRIPTS)
-check: test pep8 run-tests
+check: test-devbot pep8 run-tests