Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.config3
-rw-r--r--commands/common.py9
-rw-r--r--config/modules/system-3.6.json31
-rw-r--r--config/modules/system.json (renamed from config/modules/system-3.4.json)8
-rw-r--r--config/packages/deps.json40
-rw-r--r--devbot/config.py8
-rw-r--r--devbot/plugins/debian.py2
-rw-r--r--devbot/plugins/fedora.py4
-rw-r--r--devbot/plugins/interfaces.py6
-rw-r--r--devbot/plugins/ubuntu.py4
-rw-r--r--devbot/plugins/unknown.py2
11 files changed, 39 insertions, 78 deletions
diff --git a/Makefile.config b/Makefile.config
index 467c1c1..95883c1 100644
--- a/Makefile.config
+++ b/Makefile.config
@@ -15,8 +15,7 @@ CONFIG_MODULES_DIR=config/modules
CONFIG_MODULES= \
$(CONFIG_MODULES_DIR)/activities.json \
$(CONFIG_MODULES_DIR)/sugar.json \
- $(CONFIG_MODULES_DIR)/system-3.4.json \
- $(CONFIG_MODULES_DIR)/system-3.6.json
+ $(CONFIG_MODULES_DIR)/system.json
CONFIG_PACKAGES_DIR=config/packages
diff --git a/commands/common.py b/commands/common.py
index 677417a..38c3418 100644
--- a/commands/common.py
+++ b/commands/common.py
@@ -6,9 +6,7 @@ tests_dir = os.path.join(base_dir, "tests")
sys.path.append(base_dir)
-from devbot import system
from devbot import config
-from devbot import distro
from devbot import command
def setup():
@@ -29,12 +27,7 @@ def setup():
config.set_prefs_path(os.path.join(base_dir, "prefs"))
config.set_logs_dir(logs_dir)
- os.environ["SB_LOGS_DIR"] = logs_dir
- os.environ["SB_LIBEXEC_DIR"] = config.libexec_dir
-
- version = distro.get_distro_info().system_version
-
- module_files = ["system-%s.json" % version,
+ module_files = ["system.json",
"sugar.json",
"activities.json"]
diff --git a/config/modules/system-3.6.json b/config/modules/system-3.6.json
deleted file mode 100644
index 6129135..0000000
--- a/config/modules/system-3.6.json
+++ /dev/null
@@ -1,31 +0,0 @@
-[
- {
- "branch": "2.34.2",
- "name": "glib",
- "options": [
- "--disable-modular-tests"
- ],
- "repo": "git://git.gnome.org/glib"
- },
- {
- "branch": "GOBJECT_INTROSPECTION_1_34_1_1",
- "name": "gobject-introspection",
- "options": [
- "--disable-tests"
- ],
- "repo": "git://git.gnome.org/gobject-introspection"
- },
- {
- "branch": "776088b4d673183264893cf40bd3e4e359ba7a5",
- "name": "pygobject",
- "repo": "git://git.gnome.org/pygobject"
- },
- {
- "branch": "METACITY_2_34_13",
- "name": "metacity",
- "options": [
- "--disable-themes-documentation"
- ],
- "repo": "git://git.gnome.org/metacity"
- }
-]
diff --git a/config/modules/system-3.4.json b/config/modules/system.json
index 3804470..2f3b73f 100644
--- a/config/modules/system-3.4.json
+++ b/config/modules/system.json
@@ -22,26 +22,31 @@
},
{
"branch": "ATK_2_6_0",
+ "if": "gnome_version == '3.4'",
"name": "atk",
"repo": "git://git.gnome.org/atk"
},
{
"branch": "AT_SPI2_CORE_2_6_1",
+ "if": "gnome_version == '3.4'",
"name": "at-spi2-core",
"repo": "git://git.gnome.org/at-spi2-core"
},
{
"branch": "AT_SPI2_ATK_2_6_1",
+ "if": "gnome_version == '3.4'",
"name": "at-spi2-atk",
"repo": "git://git.gnome.org/at-spi2-atk"
},
{
"branch": "3.6.1",
+ "if": "gnome_version == '3.4'",
"name": "gtk+",
"repo": "git://git.gnome.org/gtk+"
},
{
"branch": "1.0.2",
+ "if": "gstreamer_version != '1.0'",
"name": "gstreamer",
"options": [
"--disable-gtk-doc"
@@ -51,6 +56,7 @@
},
{
"branch": "1.0.2",
+ "if": "gstreamer_version != '1.0'",
"name": "gst-plugins-base",
"options": [
"--disable-gtk-doc"
@@ -60,6 +66,7 @@
},
{
"branch": "1.0.2",
+ "if": "gstreamer_version != '1.0'",
"name": "gst-plugins-good",
"options": [
"--disable-gtk-doc"
@@ -69,6 +76,7 @@
},
{
"branch": "libxklavier-5.3",
+ "if": "gnome_version == '3.4'",
"name": "libxklavier",
"repo": "git://anongit.freedesktop.org/libxklavier"
},
diff --git a/config/packages/deps.json b/config/packages/deps.json
index 6a72773..47d66c7 100644
--- a/config/packages/deps.json
+++ b/config/packages/deps.json
@@ -82,19 +82,19 @@
],
"fedora": [
"at-spi2-core"
- ],
+ ],
"ubuntu": [
"gir1.2-atspi-2.0"
]
- },
+ },
"autodetect gstreamer": {
"fedora": [
"gstreamer1-plugins-good"
- ],
+ ],
"ubuntu": [
"gstreamer1.0-plugins-good"
]
- },
+ },
"autoreconf": {
"debian": [
"autoconf"
@@ -375,22 +375,22 @@
"gstreamer"
],
"ubuntu": [
- "gir1.2-gstreamer-1.0",
+ "gir1.2-gstreamer-1.0",
"libgstreamer1.0-0"
]
- },
+ },
"gstreamer-1.0": {
"fedora": [
"gstreamer1-devel"
- ],
+ ],
"ubuntu": [
"libgstreamer1.0-dev"
]
- },
+ },
"gstreamer-plugins-base-1.0": {
"fedora": [
"gstreamer1-plugins-base-devel"
- ],
+ ],
"ubuntu": [
"libgstreamer-plugins-base1.0-dev"
]
@@ -592,23 +592,15 @@
"ubuntu": [
"telepathy-salut"
]
- },
+ },
"pango gstreamer": {
"fedora": [
"gstreamer1-plugins-base"
- ],
+ ],
"ubuntu": [
"gstreamer1.0-x"
]
- },
- "playback gstreamer": {
- "fedora": [
- "gstreamer1-plugins-base"
- ],
- "ubuntu": [
- "gstreamer1.0-plugins-base"
- ]
- },
+ },
"pkg-config": {
"debian": [
"pkg-config"
@@ -620,6 +612,14 @@
"pkgconfig"
]
},
+ "playback gstreamer": {
+ "fedora": [
+ "gstreamer1-plugins-base"
+ ],
+ "ubuntu": [
+ "gstreamer1.0-plugins-base"
+ ]
+ },
"pycairo": {
"debian": [
"python-cairo-dev"
diff --git a/devbot/config.py b/devbot/config.py
index 259c4f2..513fe10 100644
--- a/devbot/config.py
+++ b/devbot/config.py
@@ -233,8 +233,6 @@ def _filter_if(item):
return eval(item["if"], globals)
def load_checks():
- version = distro.get_distro_info().system_version
-
checks = []
for file in dep_files:
path = os.path.join(config_dir, "deps", "%s.json" % file)
@@ -243,11 +241,7 @@ def load_checks():
return filter(_filter_if, checks)
def load_modules():
- version = distro.get_distro_info().system_version
-
- module_files = ["system-%s.json" % version,
- "sugar.json",
- "activities.json"]
+ global module_files
modules = []
diff --git a/devbot/plugins/debian.py b/devbot/plugins/debian.py
index 38d5be4..09f8abc 100644
--- a/devbot/plugins/debian.py
+++ b/devbot/plugins/debian.py
@@ -89,7 +89,7 @@ class DistroInfo(interfaces.DistroInfo):
self.name = "debian"
self.version = "unknown"
- self.system_version = "3.4"
+ self.gnome_version = "3.4"
self.gstreamer_version = "0.10"
self.valid = True
self.supported = (arch in ["i686", "x86_64"])
diff --git a/devbot/plugins/fedora.py b/devbot/plugins/fedora.py
index 3cfdfef..60d73d8 100644
--- a/devbot/plugins/fedora.py
+++ b/devbot/plugins/fedora.py
@@ -87,7 +87,7 @@ class DistroInfo(interfaces.DistroInfo):
self.name = "fedora"
self.version = "unknown"
- self.system_version = "3.6"
+ self.gnome_version = "3.6"
self.gstreamer_version = "1.0"
self.use_lib64 = (arch == "x86_64")
self.valid = True
@@ -101,7 +101,7 @@ class DistroInfo(interfaces.DistroInfo):
if release == "Fedora release 17 (Beefy Miracle)":
self.version = "17"
- self.system_version = "3.4"
+ self.gnome_version = "3.4"
self.gstreamer_version = "0.10"
elif release == "Fedora release 18 (Spherical Cow)":
self.version = "18"
diff --git a/devbot/plugins/interfaces.py b/devbot/plugins/interfaces.py
index c6db014..d8659bf 100644
--- a/devbot/plugins/interfaces.py
+++ b/devbot/plugins/interfaces.py
@@ -43,10 +43,8 @@ class DistroInfo:
self.version = None
"""The distribution version."""
- self.system_version = None
- """A distribution independent system version, normally the same
- major version of GNOME installed on the system.
- """
+ self.gnome_version = None
+ """The major version of GNOME shipped with the distribution."""
self.gstreamer_version = None
"""The version of gstreamer shipped with the distribution."""
diff --git a/devbot/plugins/ubuntu.py b/devbot/plugins/ubuntu.py
index 556aaab..eaeb482 100644
--- a/devbot/plugins/ubuntu.py
+++ b/devbot/plugins/ubuntu.py
@@ -12,7 +12,7 @@ class DistroInfo(interfaces.DistroInfo):
self.name = "ubuntu"
self.version = "unknown"
- self.system_version = "3.4"
+ self.gnome_version = "3.4"
self.gstreamer_version = "1.0"
self.valid = True
self.supported = (arch in ["i386", "i686", "x86_64"])
@@ -27,7 +27,7 @@ class DistroInfo(interfaces.DistroInfo):
self.supported = False
if self.version and self.version >= "12.10":
- self.system_version = "3.6"
+ self.gnome_version = "3.6"
def _get_distributor(self):
try:
diff --git a/devbot/plugins/unknown.py b/devbot/plugins/unknown.py
index f843fd5..8589ef6 100644
--- a/devbot/plugins/unknown.py
+++ b/devbot/plugins/unknown.py
@@ -31,7 +31,7 @@ class DistroInfo(interfaces.DistroInfo):
self.use_lib64 = os.path.exists("/usr/lib64")
self.name = "unknown"
self.version = "unknown"
- self.system_version = "3.4"
+ self.gnome_version = "3.4"
self.gstreamer_version = "0.10"
self.valid = True
self.supported = False