Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.config3
-rw-r--r--commands/common.py2
-rw-r--r--config/packages/deps-3.6.json683
-rw-r--r--config/packages/deps.json (renamed from config/packages/deps-3.4.json)59
4 files changed, 56 insertions, 691 deletions
diff --git a/Makefile.config b/Makefile.config
index 913c8f8..467c1c1 100644
--- a/Makefile.config
+++ b/Makefile.config
@@ -23,8 +23,7 @@ CONFIG_PACKAGES_DIR=config/packages
OONFIG_PACKAGES= \
$(CONFIG_PACKAGES_DIR)/basesystem.json \
$(CONFIG_PACKAGES_DIR)/buildslave.json \
- $(CONFIG_PACKAGES_DIR)/deps-3.4.json \
- $(CONFIG_PACKAGES_DIR)/deps-3.6.json
+ $(CONFIG_PACKAGES_DIR)/deps.json
config-normalize:
@$(JSON_NORMALIZE) $(CONFIG_MODULES) $(OONFIG_PACKAGES)
diff --git a/commands/common.py b/commands/common.py
index 54d20b2..677417a 100644
--- a/commands/common.py
+++ b/commands/common.py
@@ -48,7 +48,7 @@ def setup():
config.set_dep_files(dep_files)
package_files = ["basesystem",
- "deps-%s" % version]
+ "deps"]
if "SUGAR_BUILDBOT" in os.environ:
package_files.append("buildslave")
diff --git a/config/packages/deps-3.6.json b/config/packages/deps-3.6.json
deleted file mode 100644
index 061eb0e..0000000
--- a/config/packages/deps-3.6.json
+++ /dev/null
@@ -1,683 +0,0 @@
-{
- "Adwaita": {
- "fedora": [
- "gnome-themes-standard"
- ],
- "ubuntu": [
- "gnome-themes-standard"
- ]
- },
- "X": {
- "fedora": [
- "xorg-x11-server-Xorg"
- ],
- "ubuntu": [
- "xserver-xorg"
- ]
- },
- "Xephyr": {
- "fedora": [
- "xorg-x11-server-Xephyr"
- ],
- "ubuntu": [
- "xserver-xephyr"
- ]
- },
- "Xvfb": {
- "fedora": [
- "xorg-x11-server-Xvfb"
- ],
- "ubuntu": [
- "xvfb"
- ]
- },
- "aclocal": {
- "fedora": [
- "automake"
- ],
- "ubuntu": [
- "automake"
- ]
- },
- "alsa": {
- "fedora": [
- "alsa-lib-devel"
- ],
- "ubuntu": [
- "libasound2-dev"
- ]
- },
- "atk-bridge": {
- "fedora": [
- "at-spi2-atk"
- ],
- "ubuntu": [
- "libatk-adaptor"
- ]
- },
- "atspi typelib": {
- "fedora": [
- "at-spi2-core"
- ],
- "ubuntu": [
- "gir1.2-atspi-2.0"
- ]
- },
- "autodetect gstreamer": {
- "fedora": [
- "gstreamer1-plugins-good"
- ],
- "ubuntu": [
- "gstreamer1.0-plugins-good"
- ]
- },
- "autoreconf": {
- "fedora": [
- "autoconf"
- ],
- "ubuntu": [
- "autoconf"
- ]
- },
- "bison": {
- "fedora": [
- "bison"
- ],
- "ubuntu": [
- "bison"
- ]
- },
- "c++": {
- "fedora": [
- "gcc-c++"
- ],
- "ubuntu": [
- "g++"
- ]
- },
- "cairo foreign": {
- "fedora": [
- "pygobject3"
- ],
- "ubuntu": [
- "python-gi-cairo"
- ]
- },
- "cairo typelib": {
- "fedora": [
- "gobject-introspection"
- ],
- "ubuntu": [
- "gir1.2-freedesktop"
- ]
- },
- "cairo-gobject": {
- "fedora": [
- "cairo-gobject-devel"
- ],
- "ubuntu": [
- "libcairo2-dev"
- ]
- },
- "dateutil python": {
- "fedora": [
- "python-dateutil"
- ],
- "ubuntu": [
- "python-dateutil"
- ]
- },
- "dbus-launch": {
- "fedora": [
- "dbus-x11"
- ],
- "ubuntu": [
- "dbus-x11"
- ]
- },
- "dconf": {
- "fedora": [
- "dconf"
- ],
- "ubuntu": [
- "dconf"
- ]
- },
- "decorator python": {
- "fedora": [
- "python-decorator"
- ],
- "ubuntu": [
- "python-decorator"
- ]
- },
- "espeak": {
- "fedora": [
- "espeak"
- ],
- "ubuntu": [
- "espeak"
- ]
- },
- "espeak devel": {
- "fedora": [
- "espeak-devel"
- ],
- "ubuntu": [
- "libespeak-dev"
- ]
- },
- "evince typelib": {
- "fedora": [
- "evince-libs"
- ],
- "ubuntu": [
- "gir1.2-evince-3.0"
- ]
- },
- "flex": {
- "fedora": [
- "flex"
- ],
- "ubuntu": [
- "flex"
- ]
- },
- "gail gtkmodule": {
- "fedora": [
- "gtk2"
- ],
- "ubuntu": [
- "libgail-common"
- ]
- },
- "gcc": {
- "fedora": [
- "gcc"
- ],
- "ubuntu": [
- "gcc"
- ]
- },
- "gconf python": {
- "fedora": [
- "gnome-python2-gconf"
- ],
- "ubuntu": [
- "python-gconf"
- ]
- },
- "gconf typelib": {
- "fedora": [
- "GConf2"
- ],
- "ubuntu": [
- "gir1.2-gconf-2.0"
- ]
- },
- "gconf-2.0": {
- "fedora": [
- "GConf2-devel"
- ],
- "ubuntu": [
- "libgconf2-dev"
- ]
- },
- "gi python": {
- "fedora": [
- "pygobject3"
- ],
- "ubuntu": [
- "python-gi"
- ]
- },
- "glib-2.0": {
- "fedora": [
- "glib2-devel"
- ],
- "ubuntu": [
- "libglib2.0-dev"
- ]
- },
- "gnome-doc-common": {
- "fedora": [
- "gnome-common"
- ],
- "ubuntu": [
- "gnome-common"
- ]
- },
- "gnome-keyring-daemon": {
- "fedora": [
- "gnome-keyring"
- ],
- "ubuntu": [
- "gnome-keyring"
- ]
- },
- "gobject-introspection-1.0": {
- "fedora": [
- "gobject-introspection-devel"
- ],
- "ubuntu": [
- "libgirepository1.0-dev"
- ]
- },
- "gsettings-desktop-schemas": {
- "fedora": [
- "gsettings-desktop-schemas-devel"
- ],
- "ubuntu": [
- "gsettings-desktop-schemas-dev"
- ]
- },
- "gst typelib": {
- "fedora": [
- "gstreamer"
- ],
- "ubuntu": [
- "gir1.2-gstreamer-1.0",
- "libgstreamer1.0-0"
- ]
- },
- "gstreamer-1.0": {
- "fedora": [
- "gstreamer1-devel"
- ],
- "ubuntu": [
- "libgstreamer1.0-dev"
- ]
- },
- "gstreamer-plugins-base-1.0": {
- "fedora": [
- "gstreamer1-plugins-base-devel"
- ],
- "ubuntu": [
- "libgstreamer-plugins-base1.0-dev"
- ]
- },
- "gtk+-3.0": {
- "fedora": [
- "gtk3-devel"
- ],
- "ubuntu": [
- "libgtk-3-dev"
- ]
- },
- "gtk-doc": {
- "fedora": [
- "gtk-doc"
- ],
- "ubuntu": [
- "gtk-doc-tools"
- ]
- },
- "gtksource typelib": {
- "fedora": [
- "gtksourceview3"
- ],
- "ubuntu": [
- "gir1.2-gtksource-3.0"
- ]
- },
- "gtksourceview2 python": {
- "fedora": [
- "pygtksourceview"
- ],
- "ubuntu": [
- "python-gtksourceview2"
- ]
- },
- "hippo python": {
- "fedora": [
- "hippo-canvas-python"
- ],
- "ubuntu": [
- "python-hippocanvas"
- ]
- },
- "ice": {
- "fedora": [
- "libICE-devel"
- ],
- "ubuntu": [
- "libice-dev"
- ]
- },
- "icon-naming-utils": {
- "fedora": [
- "icon-naming-utils"
- ],
- "ubuntu": [
- "icon-naming-utils"
- ]
- },
- "icon-slicer": {
- "fedora": [
- "icon-slicer"
- ],
- "ubuntu": [
- "icon-slicer"
- ]
- },
- "intltoolize": {
- "fedora": [
- "intltool"
- ],
- "ubuntu": [
- "intltool"
- ]
- },
- "iso-codes": {
- "fedora": [
- "iso-codes-devel"
- ],
- "ubuntu": [
- "iso-codes"
- ]
- },
- "libcanberra-gtk": {
- "fedora": [
- "libcanberra-devel"
- ],
- "ubuntu": [
- "libcanberra-gtk-dev"
- ]
- },
- "librsvg-2.0": {
- "fedora": [
- "librsvg2-devel"
- ],
- "ubuntu": [
- "librsvg2-dev"
- ]
- },
- "libtool": {
- "fedora": [
- "libtool"
- ],
- "ubuntu": [
- "libtool"
- ]
- },
- "libxml-2.0": {
- "fedora": [
- "libxml2-devel"
- ],
- "ubuntu": [
- "libxml2-dev"
- ]
- },
- "metacity": {
- "fedora": [
- "metacity"
- ],
- "ubuntu": [
- "metacity"
- ]
- },
- "org.freedesktop.Telepathy.AccountManager": {
- "fedora": [
- "telepathy-mission-control"
- ],
- "ubuntu": [
- "telepathy-mission-control-5"
- ]
- },
- "org.freedesktop.Telepathy.ConnectionManager.gabble": {
- "fedora": [
- "telepathy-gabble"
- ],
- "ubuntu": [
- "telepathy-gabble"
- ]
- },
- "org.freedesktop.Telepathy.ConnectionManager.salut": {
- "fedora": [
- "telepathy-salut"
- ],
- "ubuntu": [
- "telepathy-salut"
- ]
- },
- "pango gstreamer": {
- "fedora": [
- "gstreamer1-plugins-base"
- ],
- "ubuntu": [
- "gstreamer1.0-x"
- ]
- },
- "pkg-config": {
- "fedora": [
- "pkgconfig"
- ],
- "ubuntu": [
- "pkgconfig"
- ]
- },
- "playback gstreamer": {
- "fedora": [
- "gstreamer1-plugins-base"
- ],
- "ubuntu": [
- "gstreamer1.0-plugins-base"
- ]
- },
- "pycairo": {
- "fedora": [
- "pycairo-devel"
- ],
- "ubuntu": [
- "python-cairo-dev"
- ]
- },
- "pygst python": {
- "fedora": [
- "gstreamer-python"
- ],
- "ubuntu": [
- "python-gst0.10"
- ]
- },
- "pygtk-2.0": {
- "fedora": [
- "pygtk2-devel"
- ],
- "ubuntu": [
- "python-gtk2-dev"
- ]
- },
- "python": {
- "fedora": [
- "python-devel"
- ],
- "ubuntu": [
- "python-dev"
- ]
- },
- "rsvg python": {
- "fedora": [
- "gnome-python2-rsvg"
- ],
- "ubuntu": [
- "python-rsvg"
- ]
- },
- "simplejson python": {
- "fedora": [
- "python-simplejson"
- ],
- "ubuntu": [
- "python-simplejson"
- ]
- },
- "sm": {
- "fedora": [
- "libSM-devel"
- ],
- "ubuntu": [
- "libsm-dev"
- ]
- },
- "sphinx-build": {
- "fedora": [
- "python-sphinx"
- ],
- "ubuntu": [
- "python-sphinx"
- ]
- },
- "ssh": {
- "fedora": [
- "openssh-clients"
- ],
- "ubuntu": [
- "openssh-client"
- ]
- },
- "tar": {
- "fedora": [
- "tar"
- ],
- "ubuntu": [
- "tar"
- ]
- },
- "telepathy python": {
- "fedora": [
- "python-telepathy"
- ],
- "ubuntu": [
- "python-telepathy"
- ]
- },
- "video4linux2": {
- "fedora": [
- "gstreamer-plugins-good"
- ],
- "ubuntu": [
- "gstreamer0.10-plugins-good"
- ]
- },
- "vte python": {
- "fedora": [
- "vte"
- ],
- "ubuntu": [
- "python-vte"
- ]
- },
- "vte typelib": {
- "fedora": [
- "vte3"
- ],
- "ubuntu": [
- "gir1.2-vte-2.90"
- ]
- },
- "webkit typelib": {
- "fedora": [
- "webkitgtk3"
- ],
- "ubuntu": [
- "gir1.2-webkit-3.0"
- ]
- },
- "wnck python": {
- "fedora": [
- "gnome-python2-libwnck"
- ],
- "ubuntu": [
- "python-wnck"
- ]
- },
- "wnck typelib": {
- "fedora": [
- "libwnck3"
- ],
- "ubuntu": [
- "gir1.2-wnck-3.0"
- ]
- },
- "x11": {
- "fedora": [
- "libX11-devel"
- ],
- "ubuntu": [
- "libx11-dev"
- ]
- },
- "xapian python": {
- "fedora": [
- "xapian-bindings-python"
- ],
- "ubuntu": [
- "python-xapian"
- ]
- },
- "xcursorgen": {
- "fedora": [
- "xorg-x11-apps"
- ],
- "ubuntu": [
- "x11-apps"
- ]
- },
- "xinit": {
- "fedora": [
- "xorg-x11-xinit"
- ],
- "ubuntu": [
- "xinit"
- ]
- },
- "xkbfile": {
- "fedora": [
- "libxkbfile-devel"
- ],
- "ubuntu": [
- "libxkbfile-dev"
- ]
- },
- "xrandr": {
- "fedora": [
- "libXrandr-devel"
- ],
- "ubuntu": [
- "libxrandr-dev"
- ]
- },
- "xrdb": {
- "fedora": [
- "xorg-x11-server-utils"
- ],
- "ubuntu": [
- "x11-xserver-utils"
- ]
- },
- "xtst": {
- "fedora": [
- "libXtst-devel"
- ],
- "ubuntu": [
- "libxtst-dev"
- ]
- },
- "xz": {
- "fedora": [
- "xz"
- ],
- "ubuntu": [
- "xz-utils"
- ]
- },
- "yasm": {
- "fedora": [
- "yasm"
- ],
- "ubuntu": [
- "yasm"
- ]
- }
-}
diff --git a/config/packages/deps-3.4.json b/config/packages/deps.json
index ad915ea..6a72773 100644
--- a/config/packages/deps-3.4.json
+++ b/config/packages/deps.json
@@ -76,6 +76,25 @@
"libatk-adaptor"
]
},
+ "atspi typelib": {
+ "debian": [
+ "gir1.2-atspi-2.0"
+ ],
+ "fedora": [
+ "at-spi2-core"
+ ],
+ "ubuntu": [
+ "gir1.2-atspi-2.0"
+ ]
+ },
+ "autodetect gstreamer": {
+ "fedora": [
+ "gstreamer1-plugins-good"
+ ],
+ "ubuntu": [
+ "gstreamer1.0-plugins-good"
+ ]
+ },
"autoreconf": {
"debian": [
"autoconf"
@@ -352,14 +371,28 @@
]
},
"gst typelib": {
- "debian": [
- "gir1.2-gstreamer-1.0"
- ],
"fedora": [
"gstreamer"
],
"ubuntu": [
- "gir1.2-gstreamer-1.0"
+ "gir1.2-gstreamer-1.0",
+ "libgstreamer1.0-0"
+ ]
+ },
+ "gstreamer-1.0": {
+ "fedora": [
+ "gstreamer1-devel"
+ ],
+ "ubuntu": [
+ "libgstreamer1.0-dev"
+ ]
+ },
+ "gstreamer-plugins-base-1.0": {
+ "fedora": [
+ "gstreamer1-plugins-base-devel"
+ ],
+ "ubuntu": [
+ "libgstreamer-plugins-base1.0-dev"
]
},
"gtk+-3.0": {
@@ -559,7 +592,23 @@
"ubuntu": [
"telepathy-salut"
]
- },
+ },
+ "pango gstreamer": {
+ "fedora": [
+ "gstreamer1-plugins-base"
+ ],
+ "ubuntu": [
+ "gstreamer1.0-x"
+ ]
+ },
+ "playback gstreamer": {
+ "fedora": [
+ "gstreamer1-plugins-base"
+ ],
+ "ubuntu": [
+ "gstreamer1.0-plugins-base"
+ ]
+ },
"pkg-config": {
"debian": [
"pkg-config"