Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile37
-rw-r--r--Makefile.buildbot7
-rw-r--r--Makefile.commands25
-rw-r--r--Makefile.helpers14
4 files changed, 44 insertions, 39 deletions
diff --git a/Makefile b/Makefile
index f639f60..f8e002c 100644
--- a/Makefile
+++ b/Makefile
@@ -1,36 +1,11 @@
-COMMANDS = $(CURDIR)/commands
+SOURCE_DIR=$(CURDIR)/source
+COMMANDS_DIR=$(CURDIR)/commands
+HELPERS_DIR=$(COMMANDS_DIR)/helpers
-.PHONY: all auto-install check-system build run test shell bug-report clean \
- upload-docs
+.PHONY: all
all: build
-auto-install:
- @$(COMMANDS)/auto-install
-
-check-system:
- @$(COMMANDS)/check-system $(ARGS)
-
-build: check-system
- @$(COMMANDS)/build
-
-run: helpers
- @$(COMMANDS)/run
-
-test: helpers
- @$(COMMANDS)/test
-
-shell: helpers
- @$(COMMANDS)/shell
-
-bug-report:
- @$(COMMANDS)/bug-report
-
-clean: clean-helpers
- @$(COMMANDS)/clean
-
-upload-docs:
- rsync -r --progress ./source/sugar-docs/build/ \
- dnarvaez@shell.sugarlabs.org:~/public_html/sugar-docs/
-
+include Makefile.commands
include Makefile.helpers
+include Makefile.buildbot
diff --git a/Makefile.buildbot b/Makefile.buildbot
new file mode 100644
index 0000000..bb20390
--- /dev/null
+++ b/Makefile.buildbot
@@ -0,0 +1,7 @@
+DOCS_SOURCE=$(SOURCE_DIR)/sugar-docs/build/
+DOCS_DEST=dnarvaez@shell.sugarlabs.org:~/public_html/sugar-docs/
+
+.PHONY: upload-docs
+
+upload-docs:
+ rsync -r --progress $(DOCS_SOURCE) $(DOCS_DEST)
diff --git a/Makefile.commands b/Makefile.commands
new file mode 100644
index 0000000..07b71b6
--- /dev/null
+++ b/Makefile.commands
@@ -0,0 +1,25 @@
+.PHONY: auto-install check-system build run test shell bug-report clean
+
+auto-install:
+ @$(COMMANDS_DIR)/auto-install
+
+check-system:
+ @$(COMMANDS_DIR)/check-system $(ARGS)
+
+build: check-system
+ @$(COMMANDS_DIR)/build
+
+run: helpers-build
+ @$(COMMANDS_DIR)/run
+
+test: helpers-build
+ @$(COMMANDS_DIR)/test
+
+shell: helpers-build
+ @$(COMMANDS_DIR)/shell
+
+bug-report:
+ @$(COMMANDS_DIR)/bug-report
+
+clean: helpers-clean
+ @$(COMMANDS_DIR)/clean
diff --git a/Makefile.helpers b/Makefile.helpers
index 69eb57e..79f30eb 100644
--- a/Makefile.helpers
+++ b/Makefile.helpers
@@ -1,17 +1,15 @@
-.PHONY: helpers clean-helpers
-
-HELPERS = $(COMMANDS)/helpers
+.PHONY: helpers-build helpers-clean
HELPERS_LIBS = $(shell pkg-config --libs xrandr x11)
$(HELPERS)/%: $(HELPERS)/%.c
gcc -o $@ $< $(HELPERS_LIBS)
-bin_HELPERS = $(HELPERS)/list-outputs \
- $(HELPERS)/find-free-display \
- $(HELPERS)/xephyr-window
+bin_HELPERS = $(HELPERS_DIR)/list-outputs \
+ $(HELPERS_DIR)/find-free-display \
+ $(HELPERS_DIR)/xephyr-window
-helpers: $(bin_HELPERS)
+helpers-build: $(bin_HELPERS)
-clean-helpers:
+helpers-clean:
rm -f $(bin_HELPERS)