Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile3
-rwxr-xr-xscripts/check-system12
m---------scripts/jhbuild0
-rw-r--r--scripts/sugar.modules8
-rw-r--r--scripts/system.modules38
5 files changed, 54 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index 0d8f61a..475b90c 100644
--- a/Makefile
+++ b/Makefile
@@ -69,6 +69,9 @@ clean:
rm -rf source/gstreamer
rm -rf source/gst-plugins-base
rm -rf source/gst-plugins-good
+ rm -rf source/gst-plugins-espeak
+ rm -rf source/sugar
+ rm -rf source/sugar-toolkit-gtk3
rm -rf source/gst-plugins-bad
rm -rf source/gst-plugins-ugly
rm -rf source/gst-ffmpeg
diff --git a/scripts/check-system b/scripts/check-system
index d29e98b..5880d27 100755
--- a/scripts/check-system
+++ b/scripts/check-system
@@ -270,6 +270,10 @@ checks = \
"checker": "binary",
"packages": { "fedora": "flex",
"ubuntu": "flex" } },
+ { "check": "xtst",
+ "checker": "pkgconfig",
+ "packages": { "fedora": "libXtst-devel",
+ "ubuntu": "libxtst-dev" } },
{ "check": "bison",
"checker": "binary",
"packages": { "fedora": "bison",
@@ -282,6 +286,14 @@ checks = \
"checker": "pkgconfig",
"packages": { "fedora": "cairo-gobject-devel",
"ubuntu": "libcairo2-dev" } },
+ { "check": "iso-codes",
+ "checker": "pkgconfig",
+ "packages": { "fedora": "iso-codes-devel",
+ "ubuntu": "iso-codes" } },
+ { "check": "xkbfile",
+ "checker": "pkgconfig",
+ "packages": { "fedora": "libxkbfile-devel",
+ "ubuntu": "libxkbfile-dev" } },
# sugar-build runtime
diff --git a/scripts/jhbuild b/scripts/jhbuild
-Subproject 9c80d873c17de8564e75fd980a3d455b314fde2
+Subproject d2e266da3d9b0437964ac59d4253480f7990fca
diff --git a/scripts/sugar.modules b/scripts/sugar.modules
index b9c4ac8..1331584 100644
--- a/scripts/sugar.modules
+++ b/scripts/sugar.modules
@@ -12,14 +12,14 @@
<dep package="sugar-datastore"/>
</dependencies>
</autotools>
- <autotools id="sugar-toolkit-gtk3">
- <branch module="sugar-toolkit-gtk3/sugar-toolkit-gtk3.git" checkoutdir="sugar-toolkit-gtk3"/>
+ <autotools id="sugar-toolkit-gtk3" supports-non-srcdir-builds="no">
+ <branch module="~manuq/sugar-toolkit-gtk3/manuqs-sugar-toolkit-gtk3.git" checkoutdir="sugar-toolkit-gtk3"/>
<dependencies>
<dep package="sugar-datastore"/>
</dependencies>
</autotools>
- <autotools id="sugar">
- <branch module="sugar/mainline.git" checkoutdir="sugar"/>
+ <autotools id="sugar" supports-non-srcdir-builds="no">
+ <branch module="~manuq/sugar/manuqs-erikos-shell-port.git" checkoutdir="sugar"/>
<dependencies>
<dep package="sugar-base"/>
<dep package="sugar-toolkit"/>
diff --git a/scripts/system.modules b/scripts/system.modules
index 2a8a66f..6dd518f 100644
--- a/scripts/system.modules
+++ b/scripts/system.modules
@@ -4,9 +4,33 @@
<repository type="git" name="git.gnome.org" href="git://git.gnome.org"/>
<repository type="git" name="github.com/dnarvaez" href="git://github.com/dnarvaez"/>
<repository type="git" name="gstreamer.freedesktop.org" href="git://anongit.freedesktop.org/gstreamer/"/>
-
+ <repository type="git" name="freedesktop.org" href="git://anongit.freedesktop.org/"/>
+ <repository type="git" name="git.sugarlabs.org" href="git://git.sugarlabs.org"/>
+ <autotools id="gtk+">
+ <branch repo="git.gnome.org"/>
+ <dependencies>
+ <dep package="atk"/>
+ </dependencies>
+ </autotools>
+ <autotools id="atk">
+ <branch repo="git.gnome.org"/>
+ <dependencies>
+ <dep package="at-spi2-atk"/>
+ </dependencies>
+ </autotools>
+ <autotools id="at-spi2-atk">
+ <branch repo="git.gnome.org"/>
+ <dependencies>
+ <dep package="at-spi2-core"/>
+ </dependencies>
+ </autotools>
+ <autotools id="at-spi2-core">
+ <branch repo="git.gnome.org"/>
+ <dependencies>
+ </dependencies>
+ </autotools>
<autotools id="pygobject">
- <branch repo="git.gnome.org" revision="4df676e10a5ea595a0d491af10268f557dd722d7"/>
+ <branch repo="git.gnome.org"/>
<dependencies>
<dep package="glib"/>
<dep package="gobject-introspection"/>
@@ -36,6 +60,12 @@
<dep package="gst-plugins-base"/>
</dependencies>
</autotools>
+ <autotools id="gst-plugins-espeak" supports-non-srcdir-builds="no">
+ <branch repo="git.sugarlabs.org" module="gst-plugins-espeak/mainline.git" checkoutdir="gst-plugins-espeak"/>
+ </autotools>
+ <autotools id="libxklavier">
+ <branch repo="freedesktop.org"/>
+ </autotools>
<autotools id="gst-plugins-bad" supports-non-srcdir-builds="no">
<branch repo="gstreamer.freedesktop.org" revision="c1923a6755ad4a71597817c267a96deed10a3b94"/>
<dependencies>
@@ -52,11 +82,13 @@
<branch repo="gstreamer.freedesktop.org" revision="6d1203e5ab574b70ba421cd2d839b9b958f23bab"/>
</autotools>
-
<metamodule id="meta-system">
<dependencies>
<dep package="pygobject"/>
+ <dep package="gtk+"/>
<dep package="gst-plugins-good"/>
+ <dep package="gst-plugins-espeak"/>
+ <dep package="libxklavier"/>
<dep package="gst-plugins-bad"/>
<dep package="gst-plugins-ugly"/>
<dep package="gst-ffmpeg"/>