Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rwxr-xr-xscripts/check-system4
-rw-r--r--scripts/system.modules24
3 files changed, 30 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 11677ce..569f320 100644
--- a/Makefile
+++ b/Makefile
@@ -73,5 +73,7 @@ clean:
rm -rf source/sugar-base
rm -rf source/sugar-toolkit-gtk3
rm -rf source/sugar-fructose
+ rm -rf source/at-spi2-core
+ rm -rf source/at-spi2-atk
rm -f logs/*.log logs/all-logs.tar.bz2
rm -f scripts/list-outputs
diff --git a/scripts/check-system b/scripts/check-system
index 1fe8b23..7b9b36e 100755
--- a/scripts/check-system
+++ b/scripts/check-system
@@ -258,6 +258,10 @@ checks = \
"checker": "binary",
"packages": { "fedora": "flex",
"ubuntu": "flex" } },
+ { "check": "xtst",
+ "checker": "pkgconfig",
+ "packages": { "fedora": "libXtst-devel",
+ "ubuntu": "libxtst-dev" } },
{ "check": "bison",
"checker": "binary",
"packages": { "fedora": "bison",
diff --git a/scripts/system.modules b/scripts/system.modules
index 52ea0cb..897058d 100644
--- a/scripts/system.modules
+++ b/scripts/system.modules
@@ -3,6 +3,29 @@
<moduleset>
<repository type="git" name="git.gnome.org" href="git://git.gnome.org"/>
<repository type="git" name="github.com/dnarvaez" href="git://github.com/dnarvaez"/>
+ <autotools id="gtk">
+ <branch repo="github.com/dnarvaez"/>
+ <dependencies>
+ <dep package="atk"/>
+ </dependencies>
+ </autotools>
+ <autotools id="atk">
+ <branch repo="git.gnome.org"/>
+ <dependencies>
+ <dep package="at-spi2-atk"/>
+ </dependencies>
+ </autotools>
+ <autotools id="at-spi2-atk" supports-non-srcdir-builds="no">
+ <branch repo="git.gnome.org"/>
+ <dependencies>
+ <dep package="at-spi2-core"/>
+ </dependencies>
+ </autotools>
+ <autotools id="at-spi2-core" supports-non-srcdir-builds="no">
+ <branch repo="git.gnome.org"/>
+ <dependencies>
+ </dependencies>
+ </autotools>
<autotools id="pygobject">
<branch repo="github.com/dnarvaez"/>
<dependencies>
@@ -23,6 +46,7 @@
<metamodule id="meta-system">
<dependencies>
<dep package="pygobject"/>
+ <dep package="gtk"/>
</dependencies>
</metamodule>
</moduleset>