Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile7
-rw-r--r--README2
-rwxr-xr-xscripts/install-activities33
3 files changed, 3 insertions, 39 deletions
diff --git a/Makefile b/Makefile
index a62feb7..8faa5bb 100644
--- a/Makefile
+++ b/Makefile
@@ -37,15 +37,12 @@ build-glucose: install-jhbuild check-system
build-fructose:
$(TYPESCRIPT) "$(JHBUILD) build sugar-fructose" $(LOGFILE)
-build: build-glucose scripts/list-outputs
-
-install-activities:
- $(LOG) "$(SCRIPTS)/install-activities" $(LOGFILE)
+build: build-glucose build-fructose
build-%:
$(TYPESCRIPT) "$(JHBUILD) buildone $*" $(LOGFILE)
-run:
+run: scripts/list-outputs
xinit $(SCRIPTS)/xinitrc -- :99
test:
diff --git a/README b/README
index fc4e7a0..63357e2 100644
--- a/README
+++ b/README
@@ -18,7 +18,7 @@ I'm hoping we can get rid of this step in the next Ubuntu version when a working
Run the commands
- make
+ make build
make run
That should be all you need to have sugar running!
diff --git a/scripts/install-activities b/scripts/install-activities
deleted file mode 100755
index c237f8d..0000000
--- a/scripts/install-activities
+++ /dev/null
@@ -1,33 +0,0 @@
-#!/bin/sh
-
-scriptsdir=`dirname "$0"`
-rootdir=`dirname "$scriptsdir"`
-activitiesdir=$rootdir/install/share/sugar/activities
-
-activities=$(cat <<EOF
-http://activities.sugarlabs.org/downloads/file/28118/browse-140.xo
-http://activities.sugarlabs.org/downloads/file/28135/terminal-40.xo
-EOF
-)
-
-mkdir -p $activitiesdir
-cd $activitiesdir
-
-for activity in $activities
-do
- curl -L -o temp.xo $activity
-
- activityinfopath=`zipinfo -1 temp.xo | grep activity.info`
- activitydir=`dirname $activityinfopath`
- rootactivitydir=`dirname $activitydir`
-
- if [ -d "$rootactivitydir" ]; then
- rm -rf $rootactivitydir
- fi
-
- unzip temp.xo
-
- rm temp.xo
-done
-
-