Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile3
-rw-r--r--commands/common.py1
-rw-r--r--devbot/config.py5
-rw-r--r--devbot/environ.py1
4 files changed, 8 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 6a10830..e121055 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,5 @@
SCRIPTS = $(CURDIR)/scripts
COMMANDS = $(CURDIR)/commands
-LOG = $(SCRIPTS)/log-command
all: build
@@ -25,7 +24,7 @@ run: x11-utils
$(SCRIPTS)/shell/start-sugar
test: x11-utils
- $(LOG) "$(SCRIPTS)/run-ui-tests" $(LOGFILE)
+ $(SCRIPTS)/run-ui-tests
shell: x11-utils
@PS1="[sugar-build \W]$$ " \
diff --git a/commands/common.py b/commands/common.py
index 1aff0c5..563783f 100644
--- a/commands/common.py
+++ b/commands/common.py
@@ -13,3 +13,4 @@ def setup():
config.set_install_dir(os.path.join(base_path, "install"))
config.set_source_dir(os.path.join(base_path, "source"))
config.set_build_dir(os.path.join(base_path, "build"))
+ config.set_commands_dir(os.path.join(base_path, "commands"))
diff --git a/devbot/config.py b/devbot/config.py
index 37f733d..248eab7 100644
--- a/devbot/config.py
+++ b/devbot/config.py
@@ -4,6 +4,7 @@ import os
from devbot import distro
config_dir = None
+commands_dir = None
install_dir = None
source_dir = None
build_dir = None
@@ -50,6 +51,10 @@ def set_build_dir(dir):
global build_dir
build_dir = dir
+def set_commands_dir(dir):
+ global commands_dir
+ commands_dir = dir
+
def load_packages():
return _load_deps_json("packages-%s" % distro.get_system_version())
diff --git a/devbot/environ.py b/devbot/environ.py
index d18370d..d4c143c 100644
--- a/devbot/environ.py
+++ b/devbot/environ.py
@@ -21,6 +21,7 @@ def _add_path(name, path):
def _setup_variables():
_add_path("LD_LIBRARY_PATH", config.lib_dir)
_add_path("PATH", config.bin_dir)
+ _add_path("PATH", config.commands_dir)
_add_path("GIO_EXTRA_MODULES",
os.path.join(config.system_lib_dir, "gio", "modules"))