Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile.commands
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.commands')
-rw-r--r--Makefile.commands25
1 files changed, 25 insertions, 0 deletions
diff --git a/Makefile.commands b/Makefile.commands
new file mode 100644
index 0000000..07b71b6
--- /dev/null
+++ b/Makefile.commands
@@ -0,0 +1,25 @@
+.PHONY: auto-install check-system build run test shell bug-report clean
+
+auto-install:
+ @$(COMMANDS_DIR)/auto-install
+
+check-system:
+ @$(COMMANDS_DIR)/check-system $(ARGS)
+
+build: check-system
+ @$(COMMANDS_DIR)/build
+
+run: helpers-build
+ @$(COMMANDS_DIR)/run
+
+test: helpers-build
+ @$(COMMANDS_DIR)/test
+
+shell: helpers-build
+ @$(COMMANDS_DIR)/shell
+
+bug-report:
+ @$(COMMANDS_DIR)/bug-report
+
+clean: helpers-clean
+ @$(COMMANDS_DIR)/clean