Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..d3f1a7b
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,32 @@
+SCRIPTS = $(CURDIR)/scripts
+JHBUILD = $(CURDIR)/build/bin/jhbuild -f $(SCRIPTS)/jhbuildrc
+
+submodules:
+ git submodule init
+ git submodule update
+
+check-system:
+ $(SCRIPTS)/check-system
+
+install-jhbuild: submodules check-system
+ cd $(SCRIPTS)/jhbuild ; \
+ ./autogen.sh --prefix=$(CURDIR)/build ; \
+ make ; make install
+
+build-activities: submodules
+ $(JHBUILD) run $(SCRIPTS)/build-activity terminal
+
+build-glucose: install-jhbuild check-system
+ $(JHBUILD) build
+
+build: build-glucose build-activities
+
+build-%:
+ $(JHBUILD) buildone $*
+
+run:
+ xinit $(SCRIPTS)/xinitrc -- :2
+
+clean:
+ rm -rf source
+ rm -rf build