Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile22
1 files changed, 12 insertions, 10 deletions
diff --git a/Makefile b/Makefile
index 9982571..7b796d5 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,3 @@
-SCRIPTS = $(CURDIR)/scripts
COMMANDS = $(CURDIR)/commands
all: build
@@ -6,13 +5,15 @@ all: build
XRANDR_LIBS = $(shell pkg-config --libs xrandr x11)
X11_LIBS = $(shell pkg-config --libs x11)
-scripts/list-outputs: scripts/list-outputs.c
- gcc -o scripts/list-outputs scripts/list-outputs.c $(XRANDR_LIBS)
+commands/helpers/list-outputs: commands/helpers/list-outputs.c
+ gcc -o commands/helpers/list-outputs \
+ commands/helpers/list-outputs.c $(XRANDR_LIBS)
-scripts/find-free-display: scripts/find-free-display.c
- gcc -o scripts/find-free-display scripts/find-free-display.c $(X11_LIBS)
+commands/helpers/find-free-display: commands/helpers/find-free-display.c
+ gcc -o commands/helpers/find-free-display \
+ commands/helpers/find-free-display.c $(X11_LIBS)
-x11-utils: scripts/list-outputs scripts/find-free-display
+x11-utils: commands/helpers/list-outputs commands/helpers/find-free-display
check-system:
$(COMMANDS)/check-system $(ARGS)
@@ -21,15 +22,16 @@ build: check-system
$(COMMANDS)/build
run: x11-utils
- $(SCRIPTS)/shell/start-sugar
+ $(COMMANDS)/run
+
+run-command: x11-utils
+ $(COMMANDS)/run-command
test: x11-utils
- $(SCRIPTS)/run-ui-tests
+ $(COMMANDS)/test
shell: x11-utils
@PS1="[sugar-build \W]$$ " \
- PATH=$(PATH):$(SCRIPTS)/shell \
- SUGAR_BUILD_SHELL=yes \
$(COMMANDS)/shell
bug-report: