Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile43
1 files changed, 39 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 9545d1d..2a28311 100644
--- a/Makefile
+++ b/Makefile
@@ -1,10 +1,45 @@
COMMANDS_DIR=$(CURDIR)/commands
-TOOLS_DIR=$(CURDIR)/tools
TIME=time -f "\n= Time =\n\nreal\t%e\nuser\t%U\nsys\t%S\n"
-.PHONY: all
+.PHONY: build
all: build
-include Makefile.config
-include Makefile.commands
+check-system:
+ @$(COMMANDS_DIR)/check-system $(ARGS)
+
+pull:
+ @$(COMMANDS_DIR)/pull $(ARGS)
+
+build:
+ @$(TIME) $(COMMANDS_DIR)/build $(ARGS)
+
+run:
+ @$(COMMANDS_DIR)/run
+
+check:
+ @$(COMMANDS_DIR)/check
+
+shell:
+ @$(COMMANDS_DIR)/shell
+
+bug-report:
+ @$(COMMANDS_DIR)/bug-report
+
+clean:
+ @$(COMMANDS_DIR)/clean
+
+distribute:
+ @$(COMMANDS_DIR)/distribute
+
+snapshot:
+ @$(COMMANDS_DIR)/snapshot
+
+build-%:
+ @$(COMMANDS_DIR)/build $*
+
+pull-%:
+ @$(COMMANDS_DIR)/pull $*
+
+check-%:
+ @$(COMMANDS_DIR)/check $*