Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/devbot/config.py
diff options
context:
space:
mode:
Diffstat (limited to 'devbot/config.py')
-rw-r--r--devbot/config.py9
1 files changed, 6 insertions, 3 deletions
diff --git a/devbot/config.py b/devbot/config.py
index be1809b..e47201c 100644
--- a/devbot/config.py
+++ b/devbot/config.py
@@ -44,6 +44,8 @@ class Module:
else:
self.out_of_source = info.get("out-of-source", True)
+ self._build_system = info.get("build-system", None)
+
def get_source_dir(self):
return os.path.join(get_source_dir(), self.name)
@@ -51,17 +53,18 @@ class Module:
return os.path.join(get_build_dir(), self.name)
def get_build_system(self):
+ if self._build_system:
+ return self._build_system
+
source_dir = self.get_source_dir()
if os.path.exists(os.path.join(source_dir, "setup.py")):
return "activity"
- elif os.path.exists(os.path.join(source_dir, "mozilla-config.h.in")):
- return "mozilla"
elif os.path.exists(os.path.join(source_dir, "autogen.sh")) or \
os.path.exists(os.path.join(source_dir, "configure")) or \
os.path.exists(os.path.join(source_dir, "Makefile")):
return "autotools"
elif os.path.exists(os.path.join(source_dir, "package.json")):
- return "node"
+ return "nodemodule"
return None