Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/devbot/config.py
diff options
context:
space:
mode:
Diffstat (limited to 'devbot/config.py')
-rw-r--r--devbot/config.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/devbot/config.py b/devbot/config.py
index 3f65417..be1809b 100644
--- a/devbot/config.py
+++ b/devbot/config.py
@@ -54,8 +54,11 @@ class Module:
source_dir = self.get_source_dir()
if os.path.exists(os.path.join(source_dir, "setup.py")):
return "activity"
+ elif os.path.exists(os.path.join(source_dir, "mozilla-config.h.in")):
+ return "mozilla"
elif os.path.exists(os.path.join(source_dir, "autogen.sh")) or \
- os.path.exists(os.path.join(source_dir, "configure")):
+ os.path.exists(os.path.join(source_dir, "configure")) or \
+ os.path.exists(os.path.join(source_dir, "Makefile")):
return "autotools"
elif os.path.exists(os.path.join(source_dir, "package.json")):
return "node"