Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/TamTamEdit.activity/setup.py
diff options
context:
space:
mode:
authorNat <natcl@hotmail.com>2007-09-17 16:50:00 (GMT)
committer Nat <natcl@hotmail.com>2007-09-17 16:50:00 (GMT)
commit2e559ace9d45bb83af07567443321cb3a41de42b (patch)
tree809e22e4c8317c4de374e487f58c24752b9c1fdc /TamTamEdit.activity/setup.py
parent608fdb2e7f7a62e08b7e29a6ba28ff6326638be9 (diff)
TamTam Edit split
Diffstat (limited to 'TamTamEdit.activity/setup.py')
-rw-r--r--TamTamEdit.activity/setup.py11
1 files changed, 10 insertions, 1 deletions
diff --git a/TamTamEdit.activity/setup.py b/TamTamEdit.activity/setup.py
index 5b21f11..b31f0b1 100644
--- a/TamTamEdit.activity/setup.py
+++ b/TamTamEdit.activity/setup.py
@@ -17,5 +17,14 @@
# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
from sugar.activity import bundlebuilder
+import shutil
+import os
-bundlebuilder.start('TamTam')
+#We are removing the symlink to common and replacing it with the real common folder
+os.system('unlink common')
+shutil.copytree('../common', 'common')
+
+bundlebuilder.start('TamTamEdit')
+#Restore the symlink
+os.system('rm -rf common')
+os.system('ln -s ../common common')