Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/TamTamSynthLab.activity/setup.py
diff options
context:
space:
mode:
authorroot <root@xo-05-29-F6.localdomain>2007-09-17 07:14:39 (GMT)
committer root <root@xo-05-29-F6.localdomain>2007-09-17 07:14:39 (GMT)
commit608fdb2e7f7a62e08b7e29a6ba28ff6326638be9 (patch)
treee52e0cf131167b1656af0ef91591df4fb4ddec57 /TamTamSynthLab.activity/setup.py
parent1306a73c218a126dfc3f74a8346144f38e5426f9 (diff)
SynthLab split
Diffstat (limited to 'TamTamSynthLab.activity/setup.py')
-rw-r--r--TamTamSynthLab.activity/setup.py11
1 files changed, 10 insertions, 1 deletions
diff --git a/TamTamSynthLab.activity/setup.py b/TamTamSynthLab.activity/setup.py
index 5b21f11..c58f78c 100644
--- a/TamTamSynthLab.activity/setup.py
+++ b/TamTamSynthLab.activity/setup.py
@@ -17,5 +17,14 @@
# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
from sugar.activity import bundlebuilder
+import shutil
+import os
-bundlebuilder.start('TamTam')
+#We are removing the symlink to common and replacing it with the real common folder
+os.system('unlink common')
+shutil.copytree('../common', 'common')
+
+bundlebuilder.start('TamTamSynthLab')
+#Restore the symlink
+os.system('rm -rf common')
+os.system('ln -s ../common common')