Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAleksey Lim <alsroot@sugarlabs.org>2011-07-29 10:44:28 (GMT)
committer Aleksey Lim <alsroot@sugarlabs.org>2011-07-29 10:44:28 (GMT)
commite9ae92b4a2fce39738ffce9edc459aad0b6ac693 (patch)
treeff6f828959b79de02d831b2b398eb3f2854e90c5 /setup.py
parent7008bcd24a9c8112c346ad78a153b53cf1a3ff61 (diff)
Translate per activity names
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py11
1 files changed, 11 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 9c6a8fb..c5f4278 100755
--- a/setup.py
+++ b/setup.py
@@ -21,10 +21,21 @@ from glob import glob
from ConfigParser import ConfigParser
from os.path import join, dirname, abspath, lexists, islink, isdir, exists
from os.path import basename
+from gettext import gettext as _
COMPONENTS = ['Edit', 'Jam', 'Mini', 'SynthLab']
+FULL_COMPONENT_NAMES = [
+ # TRANS: Full activity name that will be used in Sugar Shell
+ _('TamTamEdit'),
+ # TRANS: Full activity name that will be used in Sugar Shell
+ _('TamTamJam'),
+ # TRANS: Full activity name that will be used in Sugar Shell
+ _('TamTamMini'),
+ # TRANS: Full activity name that will be used in Sugar Shell
+ _('TamTamSynthLab')]
+
def link_activities(dst_root, cp_cmd):
for component in COMPONENTS: