Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/TamTamMini.activity/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'TamTamMini.activity/setup.py')
-rw-r--r--TamTamMini.activity/setup.py11
1 files changed, 10 insertions, 1 deletions
diff --git a/TamTamMini.activity/setup.py b/TamTamMini.activity/setup.py
index 5b21f11..87a6a08 100644
--- a/TamTamMini.activity/setup.py
+++ b/TamTamMini.activity/setup.py
@@ -17,5 +17,14 @@
# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
from sugar.activity import bundlebuilder
+import shutil
+import os
-bundlebuilder.start('TamTam')
+#We are removing the symlink to common and replacing it with the real common folder
+os.system('unlink common')
+shutil.copytree('../common', 'common')
+
+bundlebuilder.start('TamTamMini')
+#Restore the symlink
+os.system('rm -rf common')
+os.system('ln -s ../common common')