Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/arch_src/pyalsaaudio-0.2/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'arch_src/pyalsaaudio-0.2/debian/rules')
-rwxr-xr-xarch_src/pyalsaaudio-0.2/debian/rules55
1 files changed, 55 insertions, 0 deletions
diff --git a/arch_src/pyalsaaudio-0.2/debian/rules b/arch_src/pyalsaaudio-0.2/debian/rules
new file mode 100755
index 0000000..e7c42c8
--- /dev/null
+++ b/arch_src/pyalsaaudio-0.2/debian/rules
@@ -0,0 +1,55 @@
+#! /usr/bin/make -f
+
+PYDEF=$(shell pyversions -d)
+PYVERS=$(shell pyversions -r)
+
+build: build-stamp
+build-stamp:
+ dh_testdir
+ set -e; \
+ for python in $(PYVERS); do \
+ python=$$(echo $$python | sed "s/$(PYDEF)/python/"); \
+ $$python setup.py build; \
+ done
+ touch build-stamp
+
+clean:
+ dh_testdir
+ for python in $(PYVERS); do \
+ python=$$(echo $$python | sed "s/$(PYDEF)/python/"); \
+ $$python setup.py clean; \
+ done
+ rm -rf build build-stamp
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ set -e; \
+ for python in $(PYVERS); do \
+ python=$$(echo $$python | sed "s/$(PYDEF)/python/"); \
+ $$python setup.py install --root=$(CURDIR)/debian/python-alsaaudio --no-compile; \
+ done
+
+binary-indep: build install
+ # nothing to do here
+
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installdocs
+ dh_installchangelogs
+ dh_installexamples
+ dh_strip
+ dh_compress
+ dh_fixperms
+ dh_pysupport
+ dh_python
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-arch binary-indep