Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py28
1 files changed, 25 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index bd1e319..efa2159 100755
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,27 @@
#!/usr/bin/env python
-from sugar.activity import bundlebuilder
-if __name__ == "__main__":
- bundlebuilder.start()
+import os
+if 'SUGAR_ACTIVITY_ROOT' in os.environ:
+ from sugar.activity import bundlebuilder
+
+ if __name__ == "__main__":
+ bundlebuilder.start()
+else:
+ import glob, os.path, string
+ from distutils.core import setup
+
+ DATA_FILES = [
+ ('icons', glob.glob('icons/*')),
+ ('images', glob.glob('images/*')),
+ ('/usr/share/applications', ['turtleart.desktop'])
+ ]
+
+ setup (name = 'Turtle Art',
+ description = "A LOGO-like tool for teaching programming",
+ author = "Walter Bender",
+ author_email = "walter.bender@gmail.com",
+ version = '0.9.4',
+ packages = ['TurtleArt'],
+ scripts = ['turtleart'],
+ data_files = DATA_FILES,
+ )