Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 0f2c860..4233af1 100644
--- a/configure.in
+++ b/configure.in
@@ -229,6 +229,13 @@ else
CFLAGS="$CFLAGS $OSX_CFLAGS -Wall -Werror"
fi
+dnl Checking for the presence of the colorblind library.
+AC_CHECK_LIB(colorblind, colorblind_create, COLORBLIND_LIBS=-lcolorblind, have_colorblind=no)
+if test "x$COLORBLIND_LIBS" != "x" ; then
+ AC_CHECK_HEADERS([colorblind.h], have_colorblind=yes, have_colorblind=no)
+dnl AC_DEFINE(HAVE_LIBCOLORBLIND, 1, [The colorblind library is present.])
+fi
+
dnl WIN32 Specifics
AC_MSG_CHECKING([for Win32 platform in general])
case "$host" in
@@ -824,6 +831,7 @@ echo "DBUS Support (OLPC XO Sugar) = $with_dbus"
echo "GNET Networking (--enable-gnet) = $with_gnet (networking depends on this)"
echo "BINRELOC (--enable-binreloc) = $br_cv_binreloc"
echo "NSBundle (--enable-nsbundle) = $nsbundle"
+echo "Colorblind support = $have_colorblind"
echo