Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/bot/PyAIML-0.8.5/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'bot/PyAIML-0.8.5/setup.py')
-rwxr-xr-xbot/PyAIML-0.8.5/setup.py34
1 files changed, 0 insertions, 34 deletions
diff --git a/bot/PyAIML-0.8.5/setup.py b/bot/PyAIML-0.8.5/setup.py
deleted file mode 100755
index 3cc058a..0000000
--- a/bot/PyAIML-0.8.5/setup.py
+++ /dev/null
@@ -1,34 +0,0 @@
-# Command to build:
-from distutils.core import setup
-import glob
-
-package_prefix = "Lib/site-packages/aiml"
-
-setup(name="PyAIML",
- version="0.8.5",
- author="Cort Stratton",
- author_email="cort@users.sourceforge.net",
- maintainer="Cort Stratton",
- maintainer_email="cort@users.sourceforge.net",
-
- description="An interpreter package for AIML, the Artificial Intelligence Markup Language",
- long_description="""PyAIML implements an interpreter for AIML, the Artificial Intelligence
-Markup Language developed by Dr. Richard Wallace of the A.L.I.C.E. Foundation.
-It can be used to implement a conversational AI program.""",
- url="http://pyaiml.sourceforge.net/",
- platforms=["any"],
- classifiers=["Development Status :: 3 - Alpha",
- "Environment :: Console",
- "Intended Audience :: Developers",
- "Programming Language :: Python",
- "Operating System :: OS Independent",
- "Topic :: Communications :: Chat",
- "Topic :: Scientific/Engineering :: Artificial Intelligence"
- ],
-
- packages=["aiml"],
- data_files=[
- (package_prefix, glob.glob("aiml/self-test.aiml")),
- (package_prefix, glob.glob("*.txt")),
- ],
-)