Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py41
1 files changed, 41 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..b2d25ab
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,41 @@
+# (C) Copyright 2010 Bewype <http://www.bewype.org>
+
+# setuptools import
+from setuptools import setup, find_packages
+
+VERSION = '0.1'
+
+setup(
+ name='Creactivity',
+ version=VERSION,
+ description='Simple Sugar new Activity Skeleton Creator',
+ author='florent.pigout@gmail.com',
+ author_email='florent.pigout@gmail.com',
+ url='',
+ download_url='',
+ license='MIT',
+ zip_safe=False,
+ include_package_data=True,
+ packages=find_packages(),
+ install_requires=[
+ "PasteScript",
+ "Tempita",
+ ],
+ namespace_packages=[],
+ classifiers = [
+ 'Development Status :: 3 - Alpha',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'License :: OSI Approved :: MIT License',
+ 'Topic :: Software Development :: Libraries :: Python Modules'
+ ],
+ scripts=[],
+ entry_points="""
+ [paste.paster_create_template]
+ creactivity = creactivity.template:CreactivityTemplate
+ creactiweb = creactiweb.template:CreactiwebTemplate
+ creactigame = creactigame.template:CreactigameTemplate
+ creactistore = creactistore.template:CreactistoreTemplate
+ """,
+ keywords = [],
+ )