Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/build-snapshots
diff options
context:
space:
mode:
Diffstat (limited to 'build-snapshots')
-rwxr-xr-xbuild-snapshots8
1 files changed, 8 insertions, 0 deletions
diff --git a/build-snapshots b/build-snapshots
index 031d9fa..2f678db 100755
--- a/build-snapshots
+++ b/build-snapshots
@@ -39,6 +39,14 @@ gen_and_import_tarball() {
}
build() {
+ if [ -x autogen.sh ] ; then
+ ./autogen.sh
+ else
+ grep -q IT_PROG_INTLTOOL configure.ac && intltoolize -c
+ autoreconf -i
+ automake
+ fi
+ git commit -a -m "regenerate autofoo"
git-buildpackage --git-builder="pdebuild --configfile ${MYDIR}/pbuilderrc --debbuildopts '-I.git -i\.git'" --git-cleaner="fakeroot debian/rules clean" --git-no-pristine-tar --git-export-dir=../build
}