Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarco Pesenti Gritti <marco@localhost.localdomain>2007-06-04 11:12:14 (GMT)
committer Marco Pesenti Gritti <marco@localhost.localdomain>2007-06-04 11:12:14 (GMT)
commit47356c60f8590676405dff76e487eca4a823a420 (patch)
tree464a38ee3b21b1ff747e239419c97f034bafb8db /configure.ac
parent73521615d760c4c8afbdf05f7ac372ce3a6c7c62 (diff)
Modernize build scripts a bit
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac67
1 files changed, 67 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..405afa3
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,67 @@
+AC_INIT(icons)
+
+AM_CONFIG_HEADER(config.h)
+
+AM_INIT_AUTOMAKE(olpc-artwork, 0.33)
+
+# Honor aclocal flags
+ACLOCAL="$ACLOCAL $ACLOCAL_FLAGS"
+
+AM_MAINTAINER_MODE
+
+AM_DISABLE_STATIC
+
+AC_PROG_CC
+AC_HEADER_STDC
+AC_PROG_LIBTOOL
+AC_PROG_INTLTOOL
+
+PKG_CHECK_MODULES(GTK2, gtk+-2.0 >= 2.0.0,,
+ AC_MSG_ERROR([GTK+-2.0 is required to compile redhat-artwork]))
+
+GDK_PIXBUF2_CFLAGS=`$PKG_CONFIG --cflags gdk-pixbuf-2.0`
+GDK_PIXBUF2_LIBS=`$PKG_CONFIG --libs gdk-pixbuf-2.0`
+AC_SUBST(GDK_PIXBUF2_CFLAGS)
+AC_SUBST(GDK_PIXBUF2_LIBS)
+
+PKG_CHECK_MODULES(ENGINE, gtk+-2.0 >= 2.0 gobject-2.0 >= 2.0 cairo >= 0.1.1)
+
+GTK_VERSION=`$PKG_CONFIG --variable=gtk_binary_version gtk+-2.0`
+AC_SUBST(GTK_VERSION)
+
+dnl ===========================================================================
+dnl Use lots of warning flags with GCC
+
+WARN_CFLAGS=""
+if test "x$GCC" = "xyes"; then
+ WARN_CFLAGS="-Wall -Wpointer-arith -Wstrict-prototypes \
+ -Wmissing-prototypes -Wmissing-declarations \
+ -Wnested-externs -fno-strict-aliasing"
+fi
+AC_SUBST(WARN_CFLAGS)
+dnl ===========================================================================
+
+AM_GLIB_GNU_GETTEXT
+
+AC_OUTPUT([
+Makefile
+cursor/Makefile
+cursor/cursorthemegen/Makefile
+cursor/sugar/Makefile
+icons/Makefile
+icons/16x16/Makefile
+icons/16x16/stock/Makefile
+icons/16x16/stock/emoticons/Makefile
+icons/scalable/Makefile
+icons/scalable/actions/Makefile
+icons/scalable/control/Makefile
+icons/scalable/device/Makefile
+icons/scalable/stock/Makefile
+icons/scalable/object/Makefile
+gtk/Makefile
+gtk/engine/Makefile
+gtk/theme/Makefile
+matchbox/Makefile
+test/Makefile
+po/Makefile.in
+])