Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/gtk-engine/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gtk-engine/src/Makefile.am')
-rw-r--r--gtk-engine/src/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/gtk-engine/src/Makefile.am b/gtk-engine/src/Makefile.am
new file mode 100644
index 0000000..abda93e
--- /dev/null
+++ b/gtk-engine/src/Makefile.am
@@ -0,0 +1,27 @@
+INCLUDES = \
+ -DGTK_DISABLE_DEPRECATED \
+ -DGDK_DISABLE_DEPRECATED \
+ -DG_DISABLE_DEPRECATED \
+ $(ENGINE_CFLAGS) $(WARN_CFLAGS)
+
+enginedir = $(libdir)/gtk-2.0/$(GTK_VERSION)/engines
+engine_LTLIBRARIES = libolpc.la
+
+libolpc_la_SOURCES = \
+ cairo-support.c \
+ cairo-support.h \
+ general-support.h \
+ ge-support.h \
+ olpc_main.c \
+ olpc_misc.c \
+ olpc_misc.h \
+ olpc_rc_style.c \
+ olpc_rc_style.h \
+ olpc_style.h \
+ olpc_theme_draw.c \
+ widget-information.c \
+ widget-information.h
+
+libolpc_la_LDFLAGS = \
+ -avoid-version -no-undefined -module \
+ $(ENGINE_LIBS)