Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Drake <dsd@laptop.org>2011-12-13 19:47:33 (GMT)
committer Simon Schampijer <simon@schampijer.de>2011-12-13 20:35:30 (GMT)
commit4e137f6e4f131e5bb5b468d02af8f646da1fc28a (patch)
tree3e6072338b133537abd18a16985c0f1bea2c7e81 /Makefile.am
parent2bfb38ef827e31c11c3fc7c4158c08e6dc3c6bd7 (diff)
sugar-activity: import and make independent of sugar-toolkit GTK versions
As we move to adding support for a second UI toolkit (GTK+ 3.x), the sugar-activity binary used by all activities must become backend-toolkit-independent. It would be wasteful to have two backend toolkits loaded in memory, and in the GTK2/GTK3 case, it is impossible (importing both results in an instant crash). To achieve this, we split the existing sugar-toolkit activity/main.py:main() functionality into two parts, moving it into the sugar-activity binary and the Activity class as follows: 1. All toolkit-specific stuff is moved into the Activity class (i.e. everything that interacts with GTK) 2. Everything that can be reasonably/easily moved into the Activity class is also moved. 3. What remains is the stuff that is inherently involved with the construction of the Activity object, not related to UI toolkits. This is moved into the sugar-activity binary. main.py is then removed from sugar-toolkit, and sugar-activity is moved from sugar to sugar-toolkit-gtk3 in order to keep toolkit-related code with the toolkit itself. With this work done, the one remaining question is how to invoke the main loop. An optional run_main_loop() method is added to the activity class, for GTK2 this will run the GTK2 main loop, for GTK3 the GTK3 main loop will be run, etc. Signed-off-by: Daniel Drake <dsd@laptop.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6359a2b..86a095c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,4 +11,4 @@ EXTRA_DIST = \
intltool-update.in \
intltool-extract.in
-SUBDIRS = src po
+SUBDIRS = bin src po