Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py18
1 files changed, 18 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..08a657d
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,18 @@
+#!/usr/bin/python
+
+# Make the MANIFEST file. The contents of the activity folder and the NEWS and MANIFEST
+# files are already included in the .xo file which the bundlebuilder creates, so don't
+# add them to the manifest file.
+import os
+os.system("find ./ -name 'activity' -prune -o -name 'NEWS' \
+ -prune -o -name 'MANIFEST' \
+ -prune -o -name '.svn' \
+ -prune -o -name '*.pyc' \
+ -prune -o -name '*.xo' \
+ -prune -o -name '*.swp' \
+ -prune -o -name '.git*' \
+ -prune -o -type f \
+ -print > MANIFEST")
+
+from sugar.activity import bundlebuilder
+bundlebuilder.start("ElementsActivity")