Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py12
1 files changed, 12 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..6e4c8b1
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,12 @@
+#!/usr/bin/env python
+try:
+ from sugar.activity import bundlebuilder
+ bundlebuilder.start("ImageQuiz")
+except ImportError:
+ import os
+ os.system("find ./ | sed 's,^./,gtktest.activity/,g' > MANIFEST")
+ os.system('rm gtktest.xo')
+ os.chdir('..')
+ os.system('zip -r gtktest.xo gtktest.activity')
+ os.system('mv gtktest.xo ./gtktest.activity')
+ os.chdir('gtktest.activity') \ No newline at end of file