Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarco Pesenti Gritti <mpg@redhat.com>2005-07-11 17:38:35 (GMT)
committer Marco Pesenti Gritti <marco@src.gnome.org>2005-07-11 17:38:35 (GMT)
commit13c49bea656a4f495e2c4baedab130eab367ae4f (patch)
treea987238e2e9b0bed2f6312df490d96c2641fb6c9 /Makefile.am
parent0202a575af908e78d0fd9c2a1730989f499d2fb3 (diff)
Allow to enable/disable the pixbuf backend. Default to off for now. If we
2005-07-11 Marco Pesenti Gritti <mpg@redhat.com> * Makefile.am: * backend/Makefile.am: * backend/ev-document-factory.c: (ev_document_type_get_from_mime): * configure.ac: * shell/ev-document-types.c: (ev_document_types_add_filters): Allow to enable/disable the pixbuf backend. Default to off for now. If we want it enabled we should really put mime types in the desktop, implement properties etc. * properties/evince-properties.c: Initialize error to NULL. Check error is not NULL before freeing.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 8 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 67de018..ac59141 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,18 +2,22 @@ SUBDIRS = cut-n-paste po help data
# Backends
-SUBDIRS += pdf ps pixbuf
+SUBDIRS += pdf ps
+
+if ENABLE_PIXBUF
+SUBDIRS += pixbuf
+endif
if ENABLE_DJVU
- SUBDIRS += djvu
+SUBDIRS += djvu
endif
if ENABLE_TIFF
- SUBDIRS += tiff
+SUBDIRS += tiff
endif
if ENABLE_DVI
- SUBDIRS += dvi
+SUBDIRS += dvi
endif
SUBDIRS += backend