Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/backend/Makefile.am
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2006-05-02 19:02:46 (GMT)
committer Carlos Garcia Campos <carlosgc@src.gnome.org>2006-05-02 19:02:46 (GMT)
commit67297a0108ba18a69972c98ee1771c3dad41d55b (patch)
tree37e49b1a02bc066b645591156daceb11065caf36 /backend/Makefile.am
parentc9c1e2212e37fb03d5e4ce4192cfe3f8a7515c5c (diff)
Rework links system, it adds support for remote links now and it makes
2006-05-02 Carlos Garcia Campos <carlosgc@gnome.org> * backend/Makefile.am: * backend/ev-document-links.[ch]: * backend/ev-document.[ch]: * backend/ev-link-action.[ch]: * backend/ev-link-dest.[ch]: * backend/ev-link.[ch]: * pdf/ev-poppler.cc: (pdf_document_find_link_dest), (ev_link_dest_from_dest), (ev_link_from_action), (build_tree): * shell/ev-page-action.c: (build_new_tree_cb): * shell/ev-sidebar-links.c: (get_page_from_dest), (print_section_cb), (links_page_num_func), (update_page_callback): * shell/ev-view.[ch]: (ev_view_goto_dest), (ev_view_handle_link), (tip_from_link): * shell/ev-jobs.c: * shell/ev-window.[ch]: (ev_window_open_uri), (sidebar_links_link_activated_cb), (ev_view_popup_cmd_open_link): * shell/ev-application.[ch]: (ev_application_open_window), (ev_application_open_uri): Rework links system, it adds support for remote links now and it makes easier to add new kinds of actions and destinations. Fixes bug #317292
Diffstat (limited to 'backend/Makefile.am')
-rw-r--r--backend/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/backend/Makefile.am b/backend/Makefile.am
index c2adf47..db21e4c 100644
--- a/backend/Makefile.am
+++ b/backend/Makefile.am
@@ -22,6 +22,10 @@ libevbackend_la_SOURCES= \
ev-backend-marshal.c \
ev-link.c \
ev-link.h \
+ ev-link-action.c \
+ ev-link-action.h \
+ ev-link-dest.c \
+ ev-link-dest.h \
ev-document.c \
ev-document.h \
ev-document-factory.c \