Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/backend/djvu/Makefile.am
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2007-12-28 18:13:32 (GMT)
committer Carlos Garcia Campos <carlosgc@src.gnome.org>2007-12-28 18:13:32 (GMT)
commit31e16bd8f386dc292e60489d4a17227804bdc2e6 (patch)
tree84a81ef8fa45a24351f9e8f2c0e5f2eeb20064c2 /backend/djvu/Makefile.am
parent8fd7569d7f146b1b21365d5afcfb7795756e544f (diff)
Plugin system for backends. Fixes bug #351348.
2007-12-28 Carlos Garcia Campos <carlosgc@gnome.org> * configure.ac: * Makefile.am: * po/POTFILES.in: * backend/comics/Makefile.am: * backend/comics/comics-document.[ch]: * backend/comics/comicsdocument.evince-backend.in: * backend/djvu/Makefile.am: * backend/djvu/djvu-document.[ch]: * backend/djvu/djvudocument.evince-backend.in: * backend/dvi/Makefile.am: * backend/dvi/dvi-document.[c]: * backend/dvi/dvidocument.evince-backend.in: * backend/impress/Makefile.am: * backend/impress/impress-document.[ch]: * backend/impress/impressdocument.evince-backend.in: * backend/pdf/Makefile.am: * backend/pdf/ev-poppler.cc: * backend/pdf/ev-poppler.h: * backend/pdf/pdfdocument.evince-backend.in: * backend/pixbuf/Makefile.am: * backend/pixbuf/pixbuf-document.[ch]: * backend/pixbuf/pixbufdocument.evince-backend.in: * backend/ps/Makefile.am: * backend/ps/ev-spectre.[ch]: * backend/ps/ps-document.[ch]: * backend/ps/psdocument.evince-backend.in: * backend/tiff/Makefile.am: * backend/tiff/tiff-document.[ch]: * backend/tiff/tiffdocument.evince-backend.in: * libdocument/Makefile.am: * libdocument/ev-backends-manager.[ch]: * libdocument/ev-module.[ch]: * libdocument/ev-document.h: * libdocument/ev-document-factory.[ch]: (gdk_pixbuf_mime_type_list), (mime_type_supported_by_gdk_pixbuf), (get_compression_from_mime_type), (get_document_from_uri), (ev_document_factory_get_document), (file_filter_add_mime_types), (ev_document_factory_add_filters): * shell/Makefile.am: * shell/ev-window-title.c: (get_filename_from_uri): * shell/main.c: (main): * thumbnailer/Makefile.am: * thumbnailer/evince-thumbnailer.c: (main): Plugin system for backends. Fixes bug #351348. svn path=/trunk/; revision=2786
Diffstat (limited to 'backend/djvu/Makefile.am')
-rw-r--r--backend/djvu/Makefile.am44
1 files changed, 33 insertions, 11 deletions
diff --git a/backend/djvu/Makefile.am b/backend/djvu/Makefile.am
index fa44bbb..ea5f904 100644
--- a/backend/djvu/Makefile.am
+++ b/backend/djvu/Makefile.am
@@ -1,22 +1,44 @@
+backenddir = $(libdir)/evince/backends
+
INCLUDES = \
-I$(top_srcdir) \
-I$(top_srcdir)/libdocument \
-DGNOMEICONDIR=\""${prefix}/${DATADIRNAME}/pixmaps"\" \
- $(LIB_CFLAGS) \
- $(DJVU_CFLAGS)
+ -DGNOMELOCALEDIR=\"$(datadir)/locale\" \
+ $(BACKEND_CFLAGS) \
+ $(DJVU_CFLAGS) \
+ $(WARN_CFLAGS) \
+ $(DISABLE_DEPRECATED)
-noinst_LTLIBRARIES = libgtkdjvu.la
+backend_LTLIBRARIES = libdjvudocument.la
-libgtkdjvu_la_SOURCES = \
- djvu-document.c \
- djvu-document.h \
+libdjvudocument_la_SOURCES = \
+ djvu-document.c \
+ djvu-document.h \
djvu-document-private.h \
- djvu-links.c \
- djvu-links.h \
- djvu-text.c \
- djvu-text.h \
- djvu-text-page.c \
+ djvu-links.c \
+ djvu-links.h \
+ djvu-text.c \
+ djvu-text.h \
+ djvu-text-page.c \
djvu-text-page.h
+libdjvudocument_la_LDFLAGS = $(BACKEND_LIBTOOL_FLAGS)
+libdjvudocument_la_LIBADD = \
+ $(top_builddir)/libdocument/libevbackend.la \
+ $(BACKEND_LIBS) \
+ $(DJVU_LIBS)
+
+backend_in_files = djvudocument.evince-backend.in
+
+%.evince-backend: %.evince-backend.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*po) ; $(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
+
+backend_DATA = $(backend_in_files:.evince-backend.in=.evince-backend)
+
+EXTRA_DIST = $(backend_DATA)
+
+CLEANFILES = $(backend_DATA)
+
+