Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/backend/ps/Makefile.am
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2007-12-20 10:12:49 (GMT)
committer Carlos Garcia Campos <carlosgc@src.gnome.org>2007-12-20 10:12:49 (GMT)
commit945efc9392d4c4b5d6a211ed4ccac376bf8c3066 (patch)
tree497610d7dcad3b409d072946102d0847e3e81692 /backend/ps/Makefile.am
parentb4238df29948d1cbc04dd6fb78bbd0f13f172690 (diff)
Use libspectre, if available, for the ps backend. Fixes bugs #317106,
2007-12-20 Carlos Garcia Campos <carlosgc@gnome.org> * configure.ac: * backend/ps/Makefile.am: * backend/ps/ev-spectre.[ch]: Use libspectre, if available, for the ps backend. Fixes bugs #317106, #499787, #501235, #421879, #445797, #443859 and #486547. svn path=/trunk/; revision=2774
Diffstat (limited to 'backend/ps/Makefile.am')
-rw-r--r--backend/ps/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/backend/ps/Makefile.am b/backend/ps/Makefile.am
index e443b4a..921e397 100644
--- a/backend/ps/Makefile.am
+++ b/backend/ps/Makefile.am
@@ -5,8 +5,17 @@ INCLUDES = \
$(WARN_CFLAGS) \
$(DISABLE_DEPRECATED)
+if HAVE_SPECTRE
+INCLUDES += $(SPECTRE_CFLAGS)
+endif
+
noinst_LTLIBRARIES = libpsdocument.la
+if HAVE_SPECTRE
+libpsdocument_la_SOURCES = \
+ ev-spectre.c \
+ ev-spectre.h
+else
libpsdocument_la_SOURCES = \
gsio.c \
gsio.h \
@@ -19,4 +28,4 @@ libpsdocument_la_SOURCES = \
ps-interpreter.h \
gsdefaults.c \
gsdefaults.h
-
+endif