Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarco Pesenti Gritti <marco@gnome.org>2005-01-26 15:19:40 (GMT)
committer Marco Pesenti Gritti <marco@src.gnome.org>2005-01-26 15:19:40 (GMT)
commit5bde54f8810020217366ec3e9a64b44b4f6ee3c6 (patch)
tree14a7b4dbd47f20be8698c624d7c32481045b6ebd /configure.ac
parent7a0789bc8bbe25d3b0674176d2096ad126fc75a5 (diff)
Fix CID fonts with freetype 2.1.9
2005-01-26 Marco Pesenti Gritti <marco@gnome.org> * configure.ac: * pdf/splash/SplashFTFontEngine.cc: Fix CID fonts with freetype 2.1.9
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ace97ff..2a04fd8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -267,6 +267,14 @@ if test "x$FREETYPE_CONFIG" != "xno" ; then
FREETYPE_CFLAGS=`$FREETYPE_CONFIG --cflags`
FREETYPE_LIBS=`$FREETYPE_CONFIG --libs`
AC_DEFINE(HAVE_FREETYPE_H, 1, [Have FreeType2 include files])
+
+ vers=`$FREETYPE_CONFIG --version 2>/dev/null | sed -e 's/libfreetype //' | awk 'BEGIN { FS = "."; } { printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
+ if test -n "$vers" && test "$vers" -le 9005003; then
+ AC_DEFINE_UNQUOTED(HAVE_FREETYPE_217_OR_OLDER, 1, [Defines if your system has the freetype library 2.1.7 or older])
+ else
+ AC_DEFINE_UNQUOTED(HAVE_FREETYPE_217_OR_OLDER, 0, [Defines if your system has the freetype library 2.1.7 or older])
+ fi
+
fi
AC_SUBST(FREETYPE_CFLAGS)