Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNickolay V. Shmyrev <nshmyrev@yandex.ru>2005-11-14 20:26:35 (GMT)
committer Nickolay V. Shmyrev <nshmyrev@src.gnome.org>2005-11-14 20:26:35 (GMT)
commit5f07935d90bd52c9fc643b726024f328b35b5fbb (patch)
tree5e30b7ffdd5161e8ead3ad13eb74d456b56d6b3c /configure.ac
parent3a413acda20ebb24ae0256bcc0fa0919a2fd575e (diff)
Release 0.5.0
2005-11-14 Nickolay V. Shmyrev <nshmyrev@yandex.ru> * NEWS: * configure.ac: Release 0.5.0 2005-11-14 Nickolay V. Shmyrev <nshmyrev@yandex.ru> * comics/Makefile.am: * configure.ac: * shell/ev-document-types.c: (ev_document_types_add_filters): More advanced handling of custom mime type installation.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e72c105..48a937a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,7 +1,7 @@
dnl Process this file with autoconf to produce a configure script.
AC_PREREQ(2.57)
-AC_INIT(evince, 0.4.0)
+AC_INIT(evince, 0.5.0)
AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
AM_CONFIG_HEADER(config.h)
@@ -272,9 +272,19 @@ AC_ARG_ENABLE(comics,
[AC_HELP_STRING([--enable-comics], [Compile with support for comic book archives])],enable_comics=yes,enable_comics=no)
if test "x$enable_comics" = "xyes"; then
AC_DEFINE([ENABLE_COMICS], [1], [Enable support for comics.])
+
fi
AM_CONDITIONAL(ENABLE_COMICS, test x$enable_comics = xyes)
+AC_PATH_PROG(UPDATE_MIME_DB, update-mime-database, no)
+AC_SUBST(UPDATE_MIME_DB)
+
+AC_ARG_ENABLE(update-mimedb,
+ AC_HELP_STRING([--disable-update-mimedb],
+ [disable the update-mime-database after install [default=no]]),,
+ enable_update_mimedb=yes)
+AM_CONDITIONAL(ENABLE_UPDATE_MIMEDB, test x$enable_update_mimedb = xyes)
+
dnl ================== End of comic book checks ============================================
dnl =================== Mime types list ====================================================