Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2006-08-05 10:40:56 (GMT)
committer Carlos Garcia Campos <carlosgc@src.gnome.org>2006-08-05 10:40:56 (GMT)
commit63718064505c640af952c6e180b75235a1de5f14 (patch)
tree213f0d030710ece03ee26b98f878a56642382877 /configure.ac
parente47828bd9933f9a44cdfb009fdfcddfcec2748dd (diff)
Use GtkRecent instead of EggRecent when it's available. Fixes bug #349273
2006-08-05 Carlos Garcia Campos <carlosgc@gnome.org> * configure.ac: * cut-n-paste/Makefile.am: * data/evince-ui.xml: * shell/Makefile.am: * shell/ev-application.[ch]: * shell/ev-window.c: Use GtkRecent instead of EggRecent when it's available. Fixes bug #349273
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d355ff2..462891a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -167,6 +167,14 @@ if test x$HAVE_NAUTILUS = "xyes"; then
fi
AM_CONDITIONAL(HAVE_NAUTILUS, test x$HAVE_NAUTILUS = "xyes")
+dnl Check for GtkRecent
+PKG_CHECK_MODULES(GTK_RECENT, gtk+-2.0 >= 2.10.0,
+ [HAVE_GTK_RECENT=yes], [HAVE_GTK_RECENT=no])
+if test x$HAVE_GTK_RECENT = xyes; then
+ AC_DEFINE(HAVE_GTK_RECENT, 1, [defined if GtkRecent is available])
+fi
+AM_CONDITIONAL(HAVE_GTK_RECENT, test x$HAVE_GTK_RECENT = "xyes")
+
dnl GConf configuration
AM_GCONF_SOURCE_2