Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2008-01-31 11:23:08 (GMT)
committer Carlos Garcia Campos <carlosgc@src.gnome.org>2008-01-31 11:23:08 (GMT)
commitb830be70dc7c81f93a5ebd76abcc0a55b65846b4 (patch)
treeb47963ac8167976c7b9d99f2d4713bc91b8e708b /configure.ac
parent2a24c3f16f9ae6a6dc210abbef64c78aba4ddded (diff)
Use the new cairo function cairo_format_stride_for_width when available.
2008-01-31 Carlos Garcia Campos <carlosgc@gnome.org> * configure.ac: * backend/djvu/djvu-document.c: (djvu_document_render): * backend/tiff/tiff-document.c: (tiff_document_render): Use the new cairo function cairo_format_stride_for_width when available. Fixes bug #482720. svn path=/trunk/; revision=2884
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e2c9065..3ba95e4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -66,6 +66,12 @@ PKG_CHECK_MODULES(SHELL_CORE, libxml-2.0 >= $LIBXML_REQUIRED gtk+-2.0 >= $GTK_RE
BACKEND_LIBTOOL_FLAGS="-module -avoid-version"
AC_SUBST(BACKEND_LIBTOOL_FLAGS)
+dnl ===== Check special functions
+evince_save_LIBS=$LIBS
+LIBS="$LIBS $BACKEND_LIBS"
+AC_CHECK_FUNCS(cairo_format_stride_for_width)
+LIBS=$evince_save_LIBS
+
AC_ARG_WITH(keyring,
AC_HELP_STRING([--without-keyring],[disable the use of gnome-keyring]),
[case "${withval}" in