Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJonathan Blandford <jrb@redhat.com>2005-06-08 05:12:47 (GMT)
committer Jonathan Blandford <jrb@src.gnome.org>2005-06-08 05:12:47 (GMT)
commitd2222e0879e7bd247bec339105bc2c057907b9b5 (patch)
tree77d9e1f49b4dc2e9b3ed3e122d1426d74e8f5f86 /configure.ac
parentbca369672136e5ff831ece9832afd42085808fba (diff)
Use a GtkIconView in certain situations. That situation is that you're
Wed Jun 8 01:04:22 2005 Jonathan Blandford <jrb@redhat.com> * shell/ev-sidebar-thumbnails.c: Use a GtkIconView in certain situations. That situation is that you're using GTK+-HEAD with the patch at #306726 is applied, and you have a document with < 1500 pages in it. It's not quite as uniformly nice as the TreeView, but should be better in the long run. I'm pretty sure I guarded against breaking compilation with HAVE_GTK_ICON_VIEW_GET_VISIBLE_RANGE gaurds, though it's possible I missed some. * shell/ev-window.c (ev_window_init): We don't have our tree/list widget yet, so I commented that code out enable_view_actions_for_widget() for now. Need to figure this out. * shell/ev-page-action.c (match_selected_cb): emit the right signals. Our cool C-l completion now works.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f958ab2..106a8d1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -69,6 +69,11 @@ else
fi
AC_SUBST(EVINCE_DISABLE_DEPRECATED)
+evince_save_LIBS=$LIBS
+LIBS="$LIBS $GTK_LIBS"
+AC_CHECK_FUNCS(gtk_icon_view_get_visible_range)
+LIBS=$evince_save_LIBS
+
AM_GCONF_SOURCE_2
AC_PATH_PROG([GCONFTOOL], [gconftool-2], [no])